Download it now!
Bug 87969 - Incomplete display of imported .svg file with zoom levels > 110%
Summary: Incomplete display of imported .svg file with zoom levels > 110%
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
: 96844 (view as bug list)
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2015-01-02 15:34 UTC by Frederic Parrenin
Modified: 2018-06-19 11:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the svg image as imported in writer (145.34 KB, image/png)
2015-01-03 09:25 UTC, Frederic Parrenin
Details
Original SVG file (6.47 MB, image/svg+xml)
2016-01-28 16:45 UTC, Buovjaga
Details
SVG in LO Writer 6.1 beta 2 (117.83 KB, image/png)
2018-06-19 11:06 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2015-01-02 15:34:29 UTC
Steps to reproduce:
- create a new writer document
- insert the attached svg image
=> it takes a very long time to import the image
=> then when it is finally imported, you can remark that the image is incomplete
Comment 1 tommy27 2015-01-02 16:15:45 UTC
missing attachment. please upload it.
Comment 2 Frederic Parrenin 2015-01-02 17:01:04 UTC
Sorry, the attachment is actually too big.
I uploaded it here:
https://drive.google.com/file/d/0BzX8dPORePBsTFVLTzhuTVF0dTg/view?usp=sharing
Comment 3 Robinson Tryon (qubit) 2015-01-02 20:57:04 UTC
TESTING with LO 4.4.0.1 + Ubuntu 14.04

(In reply to Frederic Parrenin from comment #0)
> Steps to reproduce:

FIREFOX:
- Image opens quickly in portrait mode
- several labeled line graphs with points, scales, some line-segment-matching

WRITER:
> - create a new writer document
> - insert the attached svg image
> => it takes a very long time to import the image

- Writer freezes up for MANY minutes (testing on m1530 laptop; 4G RAM)

Whiteboard -> perf

> => then when it is finally imported, you can remark that the image is
> incomplete

NOREPRO: The document looks pretty similar to the rendering in Firefox.


DRAW:
- Open image in draw
- Missing labels, gridlines, pretty much all text
- Graph lines extend to far to the left and right of the page

I'm going to mark this one as 'NEW'. It's a performance hog in Writer, and has very bad rendering in Draw.
Comment 4 Rostislav 'R.Yu.' Okulov 2015-01-02 21:06:22 UTC
LO Writer 4.3.5 import took approximately 4 min (on i7 8Gb RAM) but all was fine.

LO Draw 4.3.5: same result with Robinson Tryon tests.
Comment 5 Frederic Parrenin 2015-01-03 09:25:01 UTC
Created attachment 111682 [details]
screenshot of the svg image as imported in writer
Comment 6 Frederic Parrenin 2015-01-03 09:26:37 UTC
Actually, the image is correctly imported but not always completely displayed, depending on the zoom level.
The attached screenshot shows how the image is displayed with a 150% zoom level.
Comment 7 Frederic Parrenin 2015-06-18 02:38:52 UTC
I can confirm this bug is still present on 4.4.4.2 on ubuntu 14.O4.
(both the slow import and the incomplete display on 150% zoom level)
Comment 8 Frederic Parrenin 2015-06-18 05:30:58 UTC
In 5.0.0.0beta3 on ubuntu 14.04, the svg image imports in ~3s on my computer, so the performance part seems fixed.
However, the image is still not completely displayed at a 150% zoom level.
Comment 9 Frederic Parrenin 2015-08-07 22:48:32 UTC
SVG image still incompletely displayed in 5.0.0.5.
Comment 10 tommy27 2015-08-10 13:14:11 UTC
thanks for update of the bu status on the latest release, however I have to tell you that you should not change the "version" field to the latest release you see the bug but to you have always to indicate always the earliest release you saw it for the first time.

so reverting to
Comment 11 Robinson Tryon (qubit) 2015-12-10 04:26:32 UTC Comment hidden (obsolete)
Comment 12 Julien Nabet 2015-12-31 16:44:13 UTC
*** Bug 96844 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2016-01-25 15:50:41 UTC
Image looks OK to me when it's imported into

Version: 5.2.0.0.alpha0+
Build ID: 0e7cd653ea90da388820220bf6a3eb140b57bbd6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-25_00:08:50
Locale: es-ES (es_ES)

thus, I close this ticket.

Please, bear in mind that svg open filter is going to be replace by svg import filter in Libreoffice 5.2, so don't reopen it if it looks incorrect in DRAW
Comment 14 Frederic Parrenin 2016-01-25 16:33:36 UTC
The displaying is still incorrect for me at a 150% zoom level in 5.2alpha.
Comment 15 Frederic Parrenin 2016-01-25 16:34:27 UTC
Forgot to say that I used the master build of today.
Comment 16 Buovjaga 2016-01-28 16:45:19 UTC
Created attachment 122259 [details]
Original SVG file

Our BZ now accepts a file this size.
Comment 17 Buovjaga 2016-01-28 16:49:02 UTC
I repro the incompleteness with > 110% zoom on Linux, but not on Windows!

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 259c1ed201f4277d74dfd600fed8c837cbf56abc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-27_00:45:12
Locale: fi-FI (fi_FI)

Ubuntu 15.10 64-bit 
Version: 5.2.0.0.alpha0+
Build ID: c43fdd74097cb12f69f86fd1217dd2f41ccae101
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2016-01-25_23:43:01
Locale: en-US (en_US.UTF-8)
Comment 18 QA Administrators 2017-10-30 08:34:03 UTC Comment hidden (obsolete)
Comment 19 Frederic Parrenin 2017-10-30 08:49:47 UTC
Strangely, the bug does not appear in 5.2.7.2, but it does appear in more recent versions (5.3.7.2, 5.4.2.2 and 6.0.0.0.alpha0).
Comment 20 Roman Kuznetsov 2018-06-19 11:06:08 UTC
Created attachment 142911 [details]
SVG in LO Writer 6.1 beta 2

SVG opens very fast and looks fine in LO Writer 6.1 beta 2

Status -> WFM