Bug Hunting Session
Bug 87998 - UI: Proposal for the creation of a search tab
Summary: UI: Proposal for the creation of a search tab
Status: RESOLVED DUPLICATE of bug 95405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks:
 
Reported: 2015-01-03 17:31 UTC by josiasmat
Modified: 2016-03-22 13:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Search sidebar in MS Word (48.45 KB, image/png)
2015-01-03 17:31 UTC, josiasmat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description josiasmat 2015-01-03 17:31:04 UTC
Created attachment 111691 [details]
Search sidebar in MS Word

I would like to suggest the creation of a new Search tab for the sidebar, to allow easy search of text and easy navigation between search results.

I attached a screenshot of MS Word 2013, which has a similar feature.
Comment 1 Cor Nouws 2015-01-03 19:17:19 UTC
Comment on attachment 111691 [details]
Search sidebar in MS Word

correct mime type
Comment 2 Cor Nouws 2015-01-03 19:22:53 UTC
Hi Josiasmat,

Thanks for filing this issue.

For me, the current search bar that works quickly with key board (Ctrl+F, <type>, Enter, Enter... ESC), is fine.

I can imagine there are some conditions for some people where an overview of the found places is handy, but I would definitely not like if that would replace the current work flow, that is fast and consumes so little space.

What is your idea about that?
Cheers,
Cor
Comment 3 Adolfo Jayme 2015-01-04 08:44:33 UTC
I agree with Cor. I prefer our browser-like, compact UI, which is IMO easier to use than Word’s Navigation panel.

(In reply to Cor Nouws from comment #2)
> I can imagine there are some conditions for some people where an overview of
> the found places is handy

A way to fix that would be live (as-you-type) search term highlighting. It would be awesome if we had that feature, similar to Safari’s implementation: http://images.macworld.com/images/howto/graphics/133441-safarifindtext.png
Comment 4 Heiko Tietze 2015-01-04 10:51:25 UTC
MS works similar to LO (ctr+f/type) but shows all occurrences and has a nice highlighting (similar to 'Find all'). I'd say we should find some good use case where this type of search is necessary and makes sense. Or do you only want to have just another fancy sidebar, josiasmat?
Comment 5 josiasmat 2015-01-05 11:35:34 UTC
(In reply to Adolfo Jayme from comment #3)
> A way to fix that would be live (as-you-type) search term highlighting. It
> would be awesome if we had that feature, similar to Safari’s implementation:
> http://images.macworld.com/images/howto/graphics/133441-safarifindtext.png

I agree that search term highlighting would be a nice feature. It would make it easier to see the correspondences accross the document.

(In reply to Heiko Tietze from comment #4)
> Or do you only want to have just another fancy sidebar, josiasmat?

Yes... maybe I'm a little too accostumed to use MS Word (I do not have much choice, my PhD supervisor only likes to use Word...). But that feature (search tab) is only a suggestion.
Comment 6 QA Administrators 2015-07-18 17:35:09 UTC Comment hidden (obsolete)
Comment 7 Adolfo Jayme 2015-07-19 22:23:37 UTC
Sorry, this shouldn’t have been NEEDINFO for so long.
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:23:51 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]
Comment 9 Yousuf Philips (jay) (retired) 2016-03-22 13:36:24 UTC
So lets close this as a duplicate, as bug 95405 has more information.

The find toolbar has its benefit for toolbar users and a find/replace sidebar tab would have usefulness for sidebar users.

*** This bug has been marked as a duplicate of bug 95405 ***