Bug 88024 - UI: heading text styles of DOCX documents saved by LibO with *spanish UI* are not recogniced by MS Word
Summary: UI: heading text styles of DOCX documents saved by LibO with *spanish UI* are...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: Other All
: medium normal
Assignee: Adolfo Jayme
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-04 18:43 UTC by Francisco
Modified: 2016-10-02 10:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file saved by LibO with spanish UI (20.84 KB, application/vnd.oasis.opendocument.text)
2015-01-04 18:43 UTC, Francisco
Details
DOCX saved by LibO with spanish UI (6.63 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-01-04 18:45 UTC, Francisco
Details
screenshot of Doc3 showing the problem (162.92 KB, image/png)
2015-01-04 18:47 UTC, Francisco
Details
DOCX saved by LibO with English UI (Workaround) (6.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-01-04 18:49 UTC, Francisco
Details
screenshot of Doc4: all headings are correctly recognized without the Spanish localization (153.22 KB, image/png)
2015-01-04 18:50 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2015-01-04 18:43:21 UTC
Created attachment 111729 [details]
ODT file saved by LibO with spanish UI

This bug is quite difficult difficult to explain, as it involves a specific behavior not present in the English UI but only in the Spanish one.

When saving a text document as DOCX, all headings styles ("Heading 1", "Heading 2", etc.) are well recognized by MS Word 2007 and 2010 with the default locale: English.

However, if applied the Spanish localization, DOCX files saved by LibO Writer name text styles in a way not recognized by MS Word. In other words, the main functionality of LibO writer is 0K!, but the problem appears only after applying the Spanish localization (I haven't tried other than Spanish, though).


Steps to reproduce:

0) Localize LibO in spanish, which is the natural choice of most users which speaks Spanish.

1) Create a text file with LibO, put some text using styles. See the attached file "Doc1-ODT saved by LibO with Spanish UI.odt"

2) Save the documen as DOCX. See file "Doc3-DOCX saved by LibO with spanish UI.docx" and close it.

3) Open this last file with MS Word.


Current result:

Headings saved by LibO are not recognized by MS Word. Moreover, MS Word creates its own heading styles, making the style list even bigger. See file "screenshot Doc3-DOCX saved by LibO with spanish UI.png"


Expected behavior:

Heading styles stores by LibO should be recognized by MS Word.


Workaround:

0) Change the localization from Spanish into English. 

1) Close and reopen the file

2) Save the file as DOCX: now all styles are recogniced by MS Word. See files "Doc4-DOCX saved by LibO with english UI.docx" and "screenshot Doc4-DOCX saved by LibO with english UI.png"
Comment 1 Francisco 2015-01-04 18:45:40 UTC
Created attachment 111730 [details]
DOCX saved by LibO with spanish UI
Comment 2 Francisco 2015-01-04 18:47:16 UTC
Created attachment 111731 [details]
screenshot of Doc3 showing the problem
Comment 3 Francisco 2015-01-04 18:49:21 UTC
Created attachment 111732 [details]
DOCX saved by LibO with English UI (Workaround)

(Workaround)
Comment 4 Francisco 2015-01-04 18:50:55 UTC
Created attachment 111733 [details]
screenshot of Doc4: all headings are correctly recognized without the Spanish localization
Comment 5 Francisco 2015-01-04 18:52:04 UTC
As an additional comment: the bug is pressent also in LibO 4.3. It is probably present also in previous versions, but LibO 4.1 is the older I have installed.
Comment 6 Buovjaga 2015-01-15 11:57:47 UTC
Reproduced from scratch using Win 7 64-bit, LibO 4.4 RC2 and Spanish UI.
Encabezado 1 style is shown in MSO 2013.
Comment 7 Octavio Alvarez 2015-01-15 17:01:02 UTC
Is Word in Spanish too? Does it make a difference to have Word in another language?
Comment 8 Buovjaga 2015-01-15 17:12:08 UTC
(In reply to Octavio Alvarez from comment #7)
> Is Word in Spanish too? Does it make a difference to have Word in another
> language?

Well the Word I tested certainly wasn't in Spanish.
Comment 9 Francisco 2015-01-30 01:41:04 UTC
The bug becomes even weirder when importing a DOCX file generated by MS Word: heading styles are correcly recogniced by Writer with Spanish UI.

However, when saving the file with LibO, it generates the styles "Encabezado 1", "Encabezado 2", etc. And, when opening with MS Word again, it generates it's own heading styles.
Comment 10 Francisco 2015-11-21 19:02:54 UTC
This bug is still present in 
Versión: 5.0.3.2
Id. de compilación: e5f16313668ac592c1bfb310f4390624e3dbfb75
Configuración regional: en-US (es_AR.UTF-8)
Comment 11 Adolfo Jayme 2016-10-01 20:04:06 UTC
I think I fixed this before the release of 5.2.0…
Comment 12 Francisco 2016-10-02 10:27:00 UTC
(In reply to Adolfo Jayme from comment #11)
> I think I fixed this before the release of 5.2.0…

Indeed. Sorry for not testing, I jumped LibO 5.1 because of some bugs and then I forgot to taste it with 5.2

Thank you for your work, Adolfo!