Bug Hunting Session
Bug 88149 - Impress causes java and itself to crash when copying a table created in the "Inspiration" template
Summary: Impress causes java and itself to crash when copying a table created in the "...
Status: RESOLVED DUPLICATE of bug 85128
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-07 09:59 UTC by Shimi Chen
Modified: 2015-01-07 12:52 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Java crash log file (130.43 KB, text/plain)
2015-01-07 09:59 UTC, Shimi Chen
Details
Example odp (139.58 KB, application/vnd.oasis.opendocument.presentation)
2015-01-07 10:01 UTC, Shimi Chen
Details
Java7 crash log file (128.99 KB, text/plain)
2015-01-07 10:34 UTC, Shimi Chen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shimi Chen 2015-01-07 09:59:35 UTC
Created attachment 111897 [details]
Java crash log file

Steps to reproduce:
1. Select the "inspiration" template included in LibreOffice.
2. Insert -> Table -> OK
3. Cntl+C to copy the selected table

Result:
LibreOffice crashes and a crash log file is generated by java. An example log file is attached. It does not matter if the template is changed after the fact, the table "remembers" it was made in the Inspiration template and will cause a crash when copying is attempted. An odp file with such a table is also attached.
Comment 1 Shimi Chen 2015-01-07 10:01:34 UTC
Created attachment 111898 [details]
Example odp
Comment 2 Shimi Chen 2015-01-07 10:34:47 UTC
Created attachment 111901 [details]
Java7 crash log file

Previous crash log was from OpenJDK 8, this one is after I tried to switch to OpenJDK 7 (same crash).
Comment 3 Shimi Chen 2015-01-07 12:52:37 UTC

*** This bug has been marked as a duplicate of bug 85128 ***