Download it now!
Bug 88181 - Sidebar: Undocked sidebar should appear in consistent/logical position
Summary: Sidebar: Undocked sidebar should appear in consistent/logical position
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-07 21:18 UTC by tmacalp
Modified: 2015-01-07 23:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of tiny undocked sidebar (177.02 KB, image/png)
2015-01-07 22:12 UTC, tmacalp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tmacalp 2015-01-07 21:18:37 UTC
Description:
Since the sidebar will be the only location for the styles and formatting dialog in 4.4.x+, I'm looking for a way to make it behave in a sane, consistent manner, hopefully similar to the old dialog.  This should be easy enough using an undocked sidebar.  The undocked sidebar pops up in a number of different positions depending on how you summon it.

I think the ideal behavior would be to have the undocked sidebar remember its last location and always be summoned there.  The previous styles and formatting dialog didn't remember it's last location, but would always open positioned relative to the right center of the main LibreOffice window.  

Currently, the sidebar does remember its position when switching between docked/undocked mode.  

But once undocked mode is enabled, dismissing and reenabling the sidebar opens it positioned at pixel 0,0 (top left) of LO's main window.  This is not ideal, since we would expect the sidebar to appear at the right side of LibreOffice.

Steps to reproduce
1. Open Writer
2. If testing using 4.3, enable sidebar.  If testing using 4.4, the sidebar will already be enabled by default.
3. Click sidebar menu button -> Undock
4. Note that by default, the undocked sidebar appears with its origin at the far left of the screen, but positioned vertically based on the top of LibreOffice's window.
5. Reposition the window on the right side of LO, where you'd expect it.
6. Dismiss the sidebar using View -> Sidebar (note that you can't close the sidebar using the "X" in its window decorations because of bug 87217)
7. Reenable the sidebar using View -> Sidebar

Expected:
The sidebar should reappear where we last positioned it on the right side of the LibreOffice window.

Actual:
The sidebar shows up positioned in the extreme top left of the main LibreOffice window.

Notes:
While it would be nice if LibreOffice remembered the position, I would be happy enough if it behaved like the current Styles dialog.  The Styles dialog always appears relative to the right center of the main LibreOffice window.

I tested this using LibreOffice 4.4.0.1 rc1 under 32bit Fedora 17.  I might be willing to blame some of the positioning on the window manager, but LibreOffice currently handles this properly with the Styles dialog.

Also, the initial undocked view is completely useless, since it is only wide enough for the category icons, but I'll report that as another bug if I can't find an existing one.
Comment 1 Joel Madero 2015-01-07 21:45:47 UTC
Ubuntu 14.04
LibreOffice 4.4 beta 2

I can't confirm the issue. For me the position is kept after I disable and then reenable the sidebar.
Comment 2 tmacalp 2015-01-07 22:12:36 UTC
Created attachment 111933 [details]
Screenshot of tiny undocked sidebar

I just tested under another environment: Fedora 20 using KDE, using a nightly of 4.4.0.1 from 2014-12-23.  As you can see in the attached screenshot, the undocked sidebar window pops up on the far left side and is unusably narrow.

Interestingly, the undocked sidebar window disappears when libreoffice loses focus.  It does reappear when LibreOffice regains focus.  Most definitely unrelated, but it's odd.
Comment 3 tmacalp 2015-01-07 23:51:38 UTC
Sorry Joel,

I was a bit hasty in my last response and mixed up my bugs. :)  I was thinking of the somewhat related bug 88182.

I've just installed LibreOffice 4.4.0.1 rc1 under an up-to-date Archbang install (openbox wm) and can't reproduce this bug.  I then tested the same version of LO under Mint 17 using XFCE and couldn't reproduce it.  LibreOffice (or possibly the WM) does appear to remember the undocked sidebar's last position.

I originally tested this using IceWM using Fedora 17, but that setup has a number of complicating attributes.  I should have tested this under different environments.  

I still want to look into this a bit more tomorrow, but I'm going to mark this as "Resolved: Invalid" until I can prove otherwise.
Comment 4 Joel Madero 2015-01-07 23:53:09 UTC
No worries. Happy to have you on board testing the hell out of LibreOffice and offering suggestions for improvement :)