Bug Hunting Session
Bug 88194 - freeze when paste into lots of cells (cell with comment)
Summary: freeze when paste into lots of cells (cell with comment)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: bibisectedNewer
Keywords: bibisected, regression
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2015-01-08 07:02 UTC by raal
Modified: 2019-06-10 12:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A7100 (117.02 KB, image/png)
2015-01-08 22:04 UTC, Rostislav 'R.Yu.' Okulov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2015-01-08 07:02:16 UTC
Version: 4.5.0.0.alpha0+
Build ID: 7f476fea47f06a7f8cc961dd4f6595a524346fa5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-27_23:36:28


Steps to reproduce:
- Create a new calc document
- Write '1' into A1 cell. Create a comment in cell A1 such as "test comment".
- Copy this cell into clipboard (ctrl + C)
- Select area A1:A3200
- Paste

Actual behaviour
100% CPU freeze for few minutes, then I killed soffice

Expected behaviour
Cells copied into area A2:A3200

I can not reproduce with LO 4.3.5, win7 -> regression
Comment 1 Joel Madero 2015-01-08 17:20:46 UTC
Ubuntu 14.04 x 64
LibreOffice 4.4 beta 2 - confirmed
LibreOffice 4.3.5.2 - no problem

Marking as:
Major - crash/hard freeze
Highest - regression + crash

MAB 4.4
Comment 2 Rostislav 'R.Yu.' Okulov 2015-01-08 22:04:40 UTC
Created attachment 111978 [details]
A7100
Comment 3 Rostislav 'R.Yu.' Okulov 2015-01-08 22:05:35 UTC
As you can see. Bug not reproducible for me with 2Gb RAM
LO 4.4 beta 2
Ubuntu 14.10 64-bit
Comment 4 Joel Madero 2015-01-08 22:41:59 UTC
Are you sure that's beta 2? It says alpha2+.

For me I have 4GB of RAM and hitting this issue consistently every time on multiple systems.
Comment 5 Rostislav 'R.Yu.' Okulov 2015-01-12 11:33:39 UTC
Ups. Anyway.

Regression does not appear in latest version of bibisect-44.tar.xz and must be younger.
Comment 6 Matthew Francis 2015-01-13 09:40:45 UTC
I couldn't reproduce this in 4.5 from the 45 bibisect tree around the time of the build in comment 0, or on current 4.5 master, or in 4.4.0.4. The paste finished in a few seconds each time
(I do have a lot of memory - 16G and 24G, but I didn't see any signs of a particular spike in usage during the paste)
Comment 7 Matúš Kukan 2015-03-26 13:41:40 UTC
I can't reproduce this in 4.4.1.2 - takes only few seconds. Do you really try with just 3200 cells? not 32000?

Pasting was fixed as part of bug 76324.

If it's really reproducible, cachegrind trace would help:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_cachegrind_trace
Get it with smaller number of cells, maybe 500, so it eventually finishes.
Comment 8 raal 2015-05-20 16:06:25 UTC
I can not reproduce with Version: 5.0.0.0.alpha1+
Build ID: 51d16cc69d8ad9065f61d108ea25d6a025a2e228
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-17_03:27:43
Comment 9 Robinson Tryon (qubit) 2015-12-17 08:43:31 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 10 b. 2019-06-04 19:46:39 UTC
sorry for bad news, 

this bug isn't solved yet, at least not in total, 

#76324 is still in state 'new', 

there is still a performance issue with files - (files not sheets, the comments on not displayed sheets seem to affect performance in the shown sheet as well), 

may be it's reduced to occur only after the first autosave, thus hidden from a fast check by testers, 

modern machines can bear more but limited amount of comments, try doubling the number of cells with comments copied until you see issues, strip the comments from the sheet, double data cells again, and you see it's lightning fast compared to half the cells but with comments. 

thus: poor performance, wasting time and energy.
Comment 11 Xisco Faulí 2019-06-04 21:06:14 UTC
Even if bug 76324 is open, it doesn't mean we have to reopen all similar bugs.
According to comment 8, this particular case is not reproducible in 5.5
Please, do not reopen it, specially after more than 4 years since it was closed.
Comment 12 b. 2019-06-05 13:57:59 UTC
@ xisco: imho it's not qualifying to close a bug just for one (false?) positive comment, (on a special machine, special OS, few comments, and not waited for autosave?), 

having a performance issue with too many comments / notes is not! solved if one user is happy with it and overlooked the problem ... 

i want to give help to identify the problem and get something done on it, for that purpose i thought - and still think - it's productive to shed light on all aspects of the issue, 

and perhaps to 'undig' some info from buried threads ... 

just an frustrated helpless attempt ... 

is it possible to close the other bugs and produce one  fresh and collect all still visible and helpful info in that? 

i'd like that ...
Comment 13 Xisco Faulí 2019-06-10 12:22:23 UTC
(In reply to b. from comment #12)
> is it possible to close the other bugs and produce one  fresh and collect
> all still visible and helpful info in that? 
> 
> i'd like that ...

Which other bugs ?