Bug 88199 - Table: Backward selection does not shrink properly
Summary: Table: Backward selection does not shrink properly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2015-01-08 12:28 UTC by Harald Koester
Modified: 2019-07-16 11:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-01-08 12:28:13 UTC
In order to reproduce the bug do this:

[1] Create a new text document and insert a table with 2 rows and 2 columns.
[2] Insert a word below table and select this word.
[3] Copy word to clipboard (Ctrl+C).
[4] Click into the second column of first row and keep mouse key pressed. Move mouse pointer to first column of first row and keep mouse key pressed. Both cells are highlighted.
[5] Move mouse pointer back to first cell of second row and release mouse key. Only this cell is highlighted.
[6] Copy clipboard to cell (Ctrl+V). The word is copied to both cells of first row. Expected: Word should only be copied to second cell.
[7] Delete highlighting of cell (Esc) and repeat step [4] and [5].
[8] Copy clipboard again to cell (Ctrl+V). In first cell of first row the word is added to the word inserted in step [6]. Expected: Word should not be added to first cell.

I checked this bug with other LO versions. In version 4.1.5 it does not appear but it exists in version 4.2.0. Hence a regression.
Comment 1 Urmas 2015-01-08 14:00:12 UTC
Confirming. If mouse/keyboard selection was ever expanded to the left/above the anchor cell, 1 extra row or column above/left will be chosen for the paste operantion.
Comment 2 QA Administrators 2016-01-17 20:04:42 UTC Comment hidden (obsolete)
Comment 3 Harald Koester 2016-01-18 19:15:32 UTC
Bug still exists in version 5.0.4 with Win7.
Comment 4 Xisco Faulí 2016-09-13 11:29:11 UTC
Adding keyword 'preBisect' as this regression was introduced before branch 4.4 and therefore it can't be bibisected as there's no bibisect repository for this branch.
Comment 5 Xisco Faulí 2017-09-29 08:52:41 UTC Comment hidden (obsolete)
Comment 6 Harald Koester 2017-11-02 12:24:53 UTC
Bug still exists with version 5.4.2 (16 bit, Win 10).
Comment 7 Harald Koester 2018-06-28 09:13:49 UTC
Bug still exists in version 6.0.5 (64 bit, Win 10).
Comment 8 QA Administrators 2019-06-29 02:57:58 UTC Comment hidden (obsolete)
Comment 9 Harald Koester 2019-07-16 11:29:22 UTC
Bug still exists in version 6.2.5 (64 bit, Win 10).