Download it now!
Bug 88306 - the sidebar buttons should be customizable
Summary: the sidebar buttons should be customizable
Status: RESOLVED DUPLICATE of bug 33223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-12 00:38 UTC by Orion
Modified: 2015-01-13 15:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orion 2015-01-12 00:38:01 UTC
I feel like this doesn't even require an explanation. I can add/remove buttons to every other toolbar. Why not this one?
Comment 1 Robinson Tryon (qubit) 2015-01-12 07:18:23 UTC
One for UX
Status -> NEW
Component -> ux-advise
Comment 2 Cor Nouws 2015-01-12 09:18:29 UTC
Hi,

(In reply to orion from comment #0)
> I feel like this doesn't even require an explanation. I can add/remove
> buttons to every other toolbar. Why not this one?

Looking at the huge vertical space, and the limited amount of panels that can be used, I would say there is no need for it.
Do you have different arguments?

thanks,
Cor
Comment 3 Orion 2015-01-12 18:34:05 UTC
The need for it would be putting buttons on it that I like to use and taking buttons off that I don't like to use. If I could customize the sidebar, I could then remove the entire Format toolbar and regain more screen space for the page. Add to that a key combo to bring up and dismiss the sidebar, and you've got a wonderfully minimalist interface where the controls are there when you need them and disappear when you don't.
Comment 4 Francisco 2015-01-12 23:42:27 UTC
(In reply to orion from comment #3)
> The need for it would be putting buttons on it that I like to use and taking
> buttons off that I don't like to use. If I could customize the sidebar, I
> could then remove the entire Format toolbar and regain more screen space for
> the page. Add to that a key combo to bring up and dismiss the sidebar, and
> you've got a wonderfully minimalist interface where the controls are there
> when you need them and disappear when you don't.

As a user, I agree with Orion's comments.
Comment 5 Cor Nouws 2015-01-13 08:30:59 UTC
But the idea that you can set any button on the side bar, also implies that all the functions are adjusted to be used from within the panel, not?
Comment 6 Cor Nouws 2015-01-13 08:31:52 UTC
I mean, if you just want buttons at the side to start the same popups/dialogs etc as you can do now with buttons at the top, then drag the tool bar to the side :)
Comment 7 V Stuart Foote 2015-01-13 15:58:42 UTC
(In reply to orion from comment #0)
> I feel like this doesn't even require an explanation. I can add/remove
> buttons to every other toolbar. Why not this one?

Sidebar is not a Toolbar, rather it is a hybrid mix of widgets.

https://wiki.openoffice.org/wiki/File:SidebarNames.png

Elements placed on the content panels and active in the deck, are selected by Tab button on the TabBar. It is more complex than simple toolbar button actions and dropdown or split menus.

That said, ability to provide user customization of the Sidebar is a long term goal.

Nothing new here, resolving this issue as duplicate of bug 33223

Follow the Sidebar from its meta bug 65138

*** This bug has been marked as a duplicate of bug 33223 ***