Bug 88413 - slow scrolling of documents with svg images
Summary: slow scrolling of documents with svg images
Status: RESOLVED DUPLICATE of bug 82214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg, perf
Depends on:
Blocks:
 
Reported: 2015-01-14 17:17 UTC by Frederic Parrenin
Modified: 2015-12-15 11:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of .odt file with an SVG image (182.39 KB, application/vnd.oasis.opendocument.text)
2015-01-14 17:17 UTC, Frederic Parrenin
Details
.odt file with an .svg and and .png image (242.87 KB, application/vnd.oasis.opendocument.text)
2015-01-15 10:22 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2015-01-14 17:17:37 UTC
Created attachment 112235 [details]
Example of .odt file with an SVG image

Steps to reproduce:
- open the .odt file attached
- try to scroll quickly (e.g. with the mouse wheel)
=> it is not possible to scroll quickly.

When you deal with document containing SVG images, this is a real annoyance.
This does not happen with png or jpg images.
Maybe SVG images should be cached for faster scrolling?
Comment 1 Robinson Tryon (qubit) 2015-01-15 04:04:23 UTC
Comment on attachment 112235 [details]
Example of .odt file with an SVG image

fix mimetype
Comment 2 Robinson Tryon (qubit) 2015-01-15 04:09:20 UTC
(In reply to Frederic Parrenin from comment #0)
> Steps to reproduce:
> - open the .odt file attached (attachment 112235 [details])
> - try to scroll quickly (e.g. with the mouse wheel)
> => it is not possible to scroll quickly.

When I try to scroll quickly, the image free..zes...and..up..dates slowly.

> When you deal with document containing SVG images, this is a real annoyance.
> This does not happen with png or jpg images.
> Maybe SVG images should be cached for faster scrolling?

IS the problem the SVG image? How does that test compare to a similar ODT with the same image in JPEG or PNG format embedded on the first page? Why don't you attach a couple of test documents, and we can take a look.

Status -> NEEDINFO

(When you're done uploading the test docs, please change status back to UNCONFIRMED. Thanks!)
Comment 3 Frederic Parrenin 2015-01-15 10:22:22 UTC
Created attachment 112284 [details]
.odt file with an .svg and and .png image

In the attached file, you have the same svg image on the first page and a png image on the second page. You will notice that the scrolling is quick enough for the png image but slow for the svg image.
Notice also that, for the svg image, the scrolling down is faster than the scrolling up.
Comment 4 Frederic Parrenin 2015-01-15 10:27:28 UTC
Here you will find 2 documents with several svg images showing the same scrolling problem:
https://drive.google.com/file/d/0BzX8dPORePBsd1dCWndlcHM3bVE/view?usp=sharing
https://drive.google.com/file/d/0BzX8dPORePBsZzFDLWdQSzR3S2M/view?usp=sharing
Comment 5 Robinson Tryon (qubit) 2015-01-15 20:51:38 UTC
(In reply to Frederic Parrenin from comment #3)
> Created attachment 112284 [details]
> .odt file with an .svg and and .png image

Thanks!

> In the attached file, you have the same svg image on the first page and a
> png image on the second page. You will notice that the scrolling is quick
> enough for the png image but slow for the svg image.

CONFIRMED with LO 4.4.0.2 + Ubuntu 14.04
The SVG is much slower; hopefully there's something we can do about speeding that up.

Status -> NEW
Whiteboard -> perf

> Notice also that, for the svg image, the scrolling down is faster than the
> scrolling up.

NOREPRO: Going both up and down is slow, but scrolling down seems a bit faster

(This makes sense to me, because when scrolling down, the SVG is the first thing on the first page, and is already fully loaded. When I put the SVG on the 2nd page, it was just as slow to scroll up as down)
Comment 6 Matthew Francis 2015-01-21 08:09:18 UTC

*** This bug has been marked as a duplicate of bug 82214 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:26:01 UTC
Migrating Whiteboard tags to Keywords: (perf, filter:svg -> filter:svgInsert)
[NinjaEdit]