Download it now!
Bug 88527 - Crash when open a Help [Hard to reproduce]
Summary: Crash when open a Help [Hard to reproduce]
Status: VERIFIED DUPLICATE of bug 88594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2015-01-17 09:39 UTC by baffclan
Modified: 2015-01-22 12:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of Recovery Dialog appears in Bug 88527 (5.16 KB, image/png)
2015-01-19 14:02 UTC, isana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2015-01-17 09:39:11 UTC
Crash when open a Help

Steps to Reproduce:
1. start LibreOfficeDev
2. appear LibreOfficeDev Window
3. press [F1] or Nenu -> Help -> LibreOfficeDev Help
4. Crash

OS:
Windows 7 Pro(x64)-JA

LibreOffice:
Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
Comment 1 Robinson Tryon (qubit) 2015-01-17 09:49:34 UTC
TESTING on Ubuntu 14.04 

TB46 doesn't have a 2015-01-17 build yet but NOREPRO with

LO Version: 4.5.0.0.alpha0+
Build ID: 84c69550bcb8139669de9cf98b51c35f21fe853d
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-13_08:44:23
Locale: en_US

Maybe Beluga can confirm this :-)
Comment 2 Buovjaga 2015-01-17 12:31:45 UTC
Tested with Japanese UI. No crash.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
Comment 3 Robinson Tryon (qubit) 2015-01-17 12:48:58 UTC
(In reply to baffclan from comment #0)
> Windows 7 Pro(x64)-JA
> Version: 4.5.0.0.alpha0+
> TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46

(In reply to Beluga from comment #2)
> Tested with Japanese UI. No crash.
> Win 7 64-bit Version: 4.5.0.0.alpha0+
> TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46

yeah, those repro environments are pretty darn close.

Summary -> [hard to repro]


baffclan: Can you reproduce this problem with any other builds of LibreOffice? (e.g. 4.3.5.2, 4.4.0.2 rc, etc... ?)
Comment 4 baffclan 2015-01-18 11:29:04 UTC
Robinson, Beluga
Thanks for comments and testing.

(In reply to Robinson Tryon (qubit) from comment #3)
> Can you reproduce this problem with any other builds of LibreOffice?
I installed en-US, ja, KeyID UI and Help files.

Cannot reproduce:
Version: 4.5.0.0.alpha0+
Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-11_23:35:39
Locale: ja_JP

Reproduce:
Version: 4.5.0.0.alpha0+
Build ID: 4c93c341be1425401112eed3581e8b8a6308880d
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-16_01:55:44
Locale: ja_JP
Comment 5 isana 2015-01-18 14:37:06 UTC
Quick note.
I couldn't reproduce in the following environment.

LibreOffice:
Version: 4.4.0.1
Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
UI: Japanese
Locale: ja_JP
helppack: ja (installed)

OS: Windows 8.1 32bit JA

Ja-help appeared without probrems.

When I set UI Language "English (USA)", operation calls the WEB page.
It's not important, but [F1] and [Menu-LibreOffice Help] calls different URL.
When no file is opened,
[F1] calls "https://help.libreoffice.org/swriter/sfx/ui/startcenter/open_all?Language=en-US&System=WIN&Version=4.4", and
[Menu-LibreOffice Help] calls "https://help.libreoffice.org/swriter/.uno:HelpIndex?Language=en-US&System=WIN&Version=4.4#bm_id3149178".
I report for some imformation.
Comment 6 isana 2015-01-19 14:02:53 UTC
Created attachment 112471 [details]
Example of Recovery Dialog appears in Bug 88527
Comment 7 isana 2015-01-19 14:50:25 UTC
Additional report. Reproduced.

[F1] or [Menu-LibreOfficeDev Help] causes LBO crush, and then LBO recovers soon showing a dialog like I attached.
Conditions for reproducing are bellow.

OS: Win-7-Pro-SP1-32bit and Win-8.1-32bit
  Format: Japanese (Japan)
  Location: Japan

LBO: 4.5.0.0.alpha0+ Win-x86@62-TDF
  Time: 2015-01-18_16:29:54 -> Reproduced
  Time: 2015-01-14_23:19:39 -> Reproduced
  Time: 2015-01-13_23:34:26 -> Not Reproduced
  Locale: ja_JP
  helppack: ja and en-US

Reproduced not only with helppack:ja, but also with helppack:en-US.
When helppack corrensponding to current UI is not installed, WEB-help is called, of course.
Comment 8 Caolán McNamara 2015-01-22 11:00:56 UTC

*** This bug has been marked as a duplicate of bug 88594 ***
Comment 9 baffclan 2015-01-22 12:12:07 UTC
-> v.