Bug 88593 - Significant numbers omitted with some column widths
Summary: Significant numbers omitted with some column widths
Status: RESOLVED DUPLICATE of bug 78503
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-19 17:28 UTC by matti.haveri
Modified: 2015-01-22 21:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot and the .ods file (164.26 KB, application/x-compressed)
2015-01-19 17:28 UTC, matti.haveri
Details
How it appears to me (151.13 KB, image/png)
2015-01-21 16:15 UTC, matti.haveri
Details
Test .ods file (17.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-21 16:17 UTC, matti.haveri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matti.haveri 2015-01-19 17:28:08 UTC
Created attachment 112490 [details]
screenshot and the .ods file

(See the attached screenshot and the .ods file)

The correct calculated value (in red) should be:

3551,6282571 (this is correctly shown in the format dialog)

...but depending on the column width (!) it is displayed in the spreadsheet as:

1,6283 (notice that the first numbers "355" are omitted)

...or depending on the column width with some other wrong value.

Using some narrower or wider column width displays the correct value in the spreadsheet.
Comment 1 m.a.riosv 2015-01-19 23:00:00 UTC
Hi @matti, thanks for repporting.

Works for me with:
Win7x64
Version: 4.3.5.1
Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889
Version: 4.3.7.0.0+
Build ID: 7a728f882b5a66d2184dcc2fbcf291b9dbba88fe
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2015-01-16_11:05:28
Comment 2 matti.haveri 2015-01-20 12:46:23 UTC
LibreOffice 4.2.3 displays the correct spreadsheet numbers in the same setup (OS X 10.10.1).

But LibreOffice 4.3.4 and 4.3.5 omit significant numbers:

Depending on the column width 3551,6282571 is displayed as:

,628
1,6283
51,62826
3552 (correct)
3551,6 (correct)
3551,63 (correct)
3551,62826 (correct)

Setting Preferences > LibreOffice Calc > Calculate > Limit decimals for general number format ON also displays the correct value for THAT SAVED spreadsheet.

Another workaround is to use some other format that GENERAL in the Format > Cells... > Numbers dialog.
Comment 3 raal 2015-01-20 12:55:15 UTC
unable to reproduce with LO .3.5.2, win7
Comment 4 Alex Thurgood 2015-01-20 13:47:06 UTC
I don't see any left truncation in my master build on OSX 10.10.1

Version: 4.5.0.0.alpha0+
Build ID: 15db0307fe6429238be72612cccd4a1df5e1e97c
Locale: fr_
Comment 5 Alex Thurgood 2015-01-20 13:48:09 UTC
As for rounding on the right hand side, this functions as designed methinks
Comment 6 Alex Thurgood 2015-01-20 13:49:45 UTC
I see no problem in 

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5

on OSX 10.10.1 either
Comment 7 Alex Thurgood 2015-01-20 13:52:14 UTC
@Matti : are you using a 32bit version of LO on OSX ?
What locale are you using ?

Setting to NEEDINFO, until requested information is provided.
Set back to unconfirmed once information has been provided.
Comment 8 m.a.riosv 2015-01-20 14:31:05 UTC
Please verify if the option:
... LibreOffice Calc/General/Use printer metrics for text formatting
change something.

If not please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 9 matti.haveri 2015-01-20 17:43:12 UTC
(In reply to Alex Thurgood from comment #7)
> @Matti : are you using a 32bit version of LO on OS X ?

Hmm I see no option to choose the bitness in OS X 10.10.1 with LibreOffice 4.3.5.2 on my Mac mini (Late 2009).

> What locale are you using ?

Finnish (but using Default - English (USA) makes no difference).
Comment 10 matti.haveri 2015-01-20 17:47:54 UTC
(In reply to m.a.riosv from comment #8)
> Please verify if the option:
> ... LibreOffice Calc/General/Use printer metrics for text formatting
> change something.

Yes, that fixed the issue! Thanks!!

Was the cause caused by my default printer HP LaserJet P1005?

> If not please try resetting the user profile, sometimes solves strange
> issues.

That makes no difference. And I was testing on a fresh install or under a guest user anyway.
Comment 11 matti.haveri 2015-01-20 19:03:06 UTC
I tried this with another newer Mac running OS X 10.10.1 (MacBook Pro Retina) with the LibreOffice 4.3.4.1 default settings:

There the incorrect values are displayed VERY briefly before changing to the correct values. I had to watch out this very carefully and even then didn't always notice it when the file opens.
Comment 12 m.a.riosv 2015-01-20 21:05:53 UTC
(In reply to matti.haveri from comment #10)
> (In reply to m.a.riosv from comment #8)
> > Please verify if the option:
> > ... LibreOffice Calc/General/Use printer metrics for text formatting
> > change something.
> 
> Yes, that fixed the issue! Thanks!!

Then seems a duplicate of 78503.
Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 78503 ***
Comment 13 matti.haveri 2015-01-21 10:01:04 UTC
This might be the same bug although in my case only certain column widths produced it:

The numbers were displayed correctly with some bigger _or_ smaller column widths.

I don't mind if the numbers are obscured with ## characters in too narrow columns.

In my case the decimal comma was misplaced so, depending on the column width, the displayed number was 70-2000 times more than it really was.

I had prepared the spreadsheet in an older version of LibreOffice and after upgrading to v4.3.4 I noticed an incorrect result in one cell (7800 * 0,45 = 1,6 WHAT?!). Now I'm a bit nervous to trust the displayed numbers.
Comment 14 matti.haveri 2015-01-21 16:15:03 UTC
Created attachment 112607 [details]
How it appears to me
Comment 15 matti.haveri 2015-01-21 16:17:13 UTC
Created attachment 112608 [details]
Test .ods file
Comment 16 m.a.riosv 2015-01-21 21:04:22 UTC
Looks fine for me.
Please take a look on the options in Menu/Tools/Options/LibreOffice/View - Graphics output.
Comment 17 matti.haveri 2015-01-22 15:26:50 UTC
I can turn off Anti-Aliasing in LibreOffice > View - Graphics output, but it does not make any difference for the misplaced decimal comma.

But:

LibreOffice Calc > General > Use printer metrics for text formatting ON

or:

LibreOffice Calc > Calculate > Limit decimals for general number format ON

do fix the issue (Locale setting Finnish -- otherwise default settings).
Comment 18 m.a.riosv 2015-01-22 21:08:57 UTC
Please @matti.haveri, comment in the duplicate bug:
https://bugs.freedesktop.org/show_bug.cgi?id=78503