Download it now!
Bug 88673 - odt file does not open because it "doesn't support tiled rendering"
Summary: odt file does not open because it "doesn't support tiled rendering"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All other
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-21 19:08 UTC by Spyros
Modified: 2015-04-24 19:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the error (57.91 KB, image/png)
2015-01-21 19:08 UTC, Spyros
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Spyros 2015-01-21 19:08:27 UTC
Created attachment 112615 [details]
Screenshot of the error

As I reported to reddit (https://www.reddit.com/r/linux/comments/2t6pxg/libreoffice_viewer_beta_now_available_for_android/cnwa1fl) I tried to open some of the huge user guides that exist on the TDF wiki (https://wiki.documentfoundation.org/Documentation/Publications) with LibreOffice Viewer Beta.

Most of them opened and loaded normally except for "LibreOffice Writer Guide: Full book (v4.2.x)" (https://wiki.documentfoundation.org/images/2/2f/WG42-WriterGuideLO.odt).

The file failed to open. Instead, it presented this error: "Cannot open WG42-WriterGuideLO.odt: Document doesn't support tiled rendering."

I'm running Android 4.4.4 on Moto G.

I can open the file normally on Ubuntu Trusty 14.04, with LibreOffice 4.2.7.2.

Spyros
Comment 1 Robinson Tryon (qubit) 2015-01-22 01:41:52 UTC
TESTING with Android 4.4.4 + LO 4.5-master

tinderbox: buildname: Android-ARM@24-Bytemark-Hosting
tinderbox: tree: MASTER
tinderbox: pull time 2015-01-21 08:36:57
tinderbox: git sha1s
core:7fe28b2c7b9a1fd5718e1f5b6562cf93902d6be0

(In reply to Spyros from comment #0)
REPRO Steps:
- Try to open large ODT (https://wiki.documentfoundation.org/images/2/2f/WG42-WriterGuideLO.odt)

RESULT: 
> The file failed to open. Instead, it presented this error: "Cannot open
> WG42-WriterGuideLO.odt: Document doesn't support tiled rendering."

CONFIRMED
Comment 2 ribotb 2015-01-25 18:49:17 UTC
Hi,

I confirm this bug for Androïd 4.4.2 on Galaxy S4.

Bernard
Comment 3 Mike Kaganski 2015-04-24 06:15:39 UTC
Works for me with Version: 4.5.0.0.alpha0+
Build ID: 6ef2c67

under Android 4.3 on GT-I9300

Please reopen if you think that it is not resolved.
Comment 4 Spyros 2015-04-24 19:32:29 UTC
(In reply to Mike Kaganski from comment #3)
> Please reopen if you think that it is not resolved.

No need; it opens for me too, in Android 5.0 with the latest LibreOffice @ Play Store update (2015-03-16). Thanks for testing! :)