Download it now!
Bug 88683 - When opened in LibreOffice, Keynote file has wrong text size and alignment
Summary: When opened in LibreOffice, Keynote file has wrong text size and alignment
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libetonyek (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: osnola
URL:
Whiteboard: filter:keynote
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-21 23:22 UTC by Adam Duston
Modified: 2018-03-21 09:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The Keynote file (171.70 KB, application/vnd.apple.keynote)
2015-01-21 23:22 UTC, Adam Duston
Details
Screenshot from Apple Keynote application (34.62 KB, image/png)
2015-01-21 23:23 UTC, Adam Duston
Details
Screenshot from LibreOffice (31.26 KB, image/png)
2015-01-21 23:24 UTC, Adam Duston
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Duston 2015-01-21 23:22:28 UTC
Created attachment 112626 [details]
The Keynote file

When I attempt to open the attached Keynote file using Keynote, I see the attached screenshot. However, I see the other attached screenshot when opening from LibreOffice.
Comment 1 Adam Duston 2015-01-21 23:23:38 UTC
Created attachment 112627 [details]
Screenshot from Apple Keynote application

This is what the file looks like in Keynote.
Comment 2 Adam Duston 2015-01-21 23:24:19 UTC
Created attachment 112628 [details]
Screenshot from LibreOffice
Comment 3 Robinson Tryon (qubit) 2015-01-22 08:08:37 UTC
TESTING on Ubuntu 14.04 + LO 4.4.0.2 and
LO Version: 4.5.0.0.alpha0+
Build ID: 84c69550bcb8139669de9cf98b51c35f21fe853d
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-13_08:44:23
Locale: en_US

(In reply to Adam Duston from comment #0)
> Created attachment 112626 [details]
> The Keynote file

Hi Adam,
Thanks for a perfect bug report!

> When I attempt to open the attached Keynote file using Keynote, I see the
> attached screenshot. However, I see the other attached screenshot when
> opening from LibreOffice.

CONFIRMED: screenshot looks exactly like rendering in 4.4.0.2 and 4.5-master

Status -> NEW
Whiteboard -> filter:keynote

Support for Keynote is in beta, but if you're interested in getting involved in library development, we'd love to have your help!
https://wiki.documentfoundation.org/DLP/Libraries/libetonyek
Comment 4 David Tardon 2018-03-21 09:30:32 UTC
Fixed by https://gerrit.libreoffice.org/gitweb?p=libetonyek.git;a=commitdiff;h=5628e391ecde8ecf1100f3a66ea0a9b1821f5046 . The fix is already present in libetonyek 0.1.7, which means it's also in libreoffice 6.0.