Bug 88694 - FILEOPEN: too many page breaks when opening .doc file
Summary: FILEOPEN: too many page breaks when opening .doc file
Status: RESOLVED DUPLICATE of bug 86468
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-01-22 08:01 UTC by Roy van der Kuil
Modified: 2015-12-15 11:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document file for testing (50.00 KB, application/msword)
2015-01-22 08:01 UTC, Roy van der Kuil
Details
preview of the document in MS Word (197.79 KB, image/jpeg)
2015-01-22 09:49 UTC, Roy van der Kuil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roy van der Kuil 2015-01-22 08:01:25 UTC
Created attachment 112646 [details]
Document file for testing

Since openoffice 4.3 (works fine in 4.2.1.1) opening the attached docfile creates too many pages.

This bug also exists in the latest 4.4 rc release (4.4.0.2)
Comment 1 Robinson Tryon (qubit) 2015-01-22 08:38:44 UTC
Comment on attachment 112646 [details]
Document file for testing

fix mimetype
Comment 2 Robinson Tryon (qubit) 2015-01-22 08:46:52 UTC
TESTING with Ubuntu 14.04 +
LO Version: 4.5.0.0.alpha0+
Build ID: 84c69550bcb8139669de9cf98b51c35f21fe853d
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-13_08:44:23
Locale: en_US

(In reply to Roy van der Kuil from comment #0)
REPRO Steps:
- Open attachment 112646 [details] in LibreOffice

RESULTS:
> Since openoffice 4.3 (works fine in 4.2.1.1) opening the attached docfile
> creates too many pages.

4.5.0.0: Displays as 2 pages
4.4.0.2: 2 pages
4.2.0.1: 1 page

CONFIRMED: There does appear to be a change in the total # of pages in the document.

Status -> NEW
keywords -> regression
whiteboard -> bibisectRequest

Roy: Please attach a screenshot of the document in Word, and let us know how many pages it is when opened in Word.
Comment 3 Roy van der Kuil 2015-01-22 09:49:26 UTC
Created attachment 112657 [details]
preview of the document in MS Word
Comment 4 Roy van der Kuil 2015-01-22 09:51:42 UTC
In MS Word the total number of pages was 1. Thank you for your quick reply!
Comment 5 Cor Nouws 2015-01-22 10:27:38 UTC
(In reply to Robinson Tryon (qubit) from comment #2)
> CONFIRMED: There does appear to be a change in the total # of pages in the
> document.

First paragraph in third section has properties text flow set to include page break.
This paragraph also has some other font information.
Comment 6 Rostislav 'R.Yu.' Okulov 2015-01-22 20:17:12 UTC
git bisect log
git bisect start
# bad: [4a3091e95fa263d3e2dd81e56e83996f0bb12287] source-hash-2b5b04e1e62914bf0902dfd7943cdc44499c47a6
git bisect bad 4a3091e95fa263d3e2dd81e56e83996f0bb12287
# good: [812c4a492375ac47b3557fbb32f5637fc89d60d9] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect good 812c4a492375ac47b3557fbb32f5637fc89d60d9
# good: [5d0dfb8e62ae61a240f8313c594d4560e7c8e048] source-hash-0c6cd530de13f80795881f61064f1bf1dcc4ea81
git bisect good 5d0dfb8e62ae61a240f8313c594d4560e7c8e048
# bad: [7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5] source-hash-f93ce4f7eb90093d0ea3115d0a1c614612676dbd
git bisect bad 7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5
# good: [1a63057f6378db7c6b8af1171b7b140f7583f246] source-hash-59f84b4a2c082382767f12e0c7a06a3f0b52e721
git bisect good 1a63057f6378db7c6b8af1171b7b140f7583f246
# bad: [2fdc98d4cfbffea5b33224bd2106aeb3b74b84a7] source-hash-d4a8fa7db0ed4faae00408fbda2352379774cfc0
git bisect bad 2fdc98d4cfbffea5b33224bd2106aeb3b74b84a7
# bad: [98aed8015d7af3a5a132192a34a4b11d8125a220] source-hash-91573182c8474297ef893f98bb04e830f3095cc2
git bisect bad 98aed8015d7af3a5a132192a34a4b11d8125a220
# bad: [ffdd7450b8a7b29a46647c85dd6d3291b1b96003] source-hash-a3fc7f20089062afa4f778e70ba8be84032a30a7
git bisect bad ffdd7450b8a7b29a46647c85dd6d3291b1b96003
# skip: [cd207063d6706c302b4d6ebe44c0ea9fcb29bd47] source-hash-057613c6864204ac5c09260e93a8f14cc9768b90
git bisect skip cd207063d6706c302b4d6ebe44c0ea9fcb29bd47
# bad: [8fa9ed399be4ea4ac5294efeae7dd5798f9ae6e2] source-hash-4a1a94dff6a76d70ee72c6c840a24953eca0a9f0
git bisect bad 8fa9ed399be4ea4ac5294efeae7dd5798f9ae6e2
# bad: [2db4c8167c9eb9e581214397fb612cbe6c3978d7] source-hash-2e0561c9962e1205b68ae0c9971c4df7b141f535
git bisect bad 2db4c8167c9eb9e581214397fb612cbe6c3978d7
# bad: [626531d9052fe067359170d41bd943b59766b551] source-hash-3d3401a6397e893808309ec374f5d8f890144906
git bisect bad 626531d9052fe067359170d41bd943b59766b551
# first bad commit: [626531d9052fe067359170d41bd943b59766b551] source-hash-3d3401a6397e893808309ec374f5d8f890144906


626531d9052fe067359170d41bd943b59766b551 is the first bad commit
commit 626531d9052fe067359170d41bd943b59766b551
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sat Oct 18 15:49:16 2014 +0000

    source-hash-3d3401a6397e893808309ec374f5d8f890144906
    
    commit 3d3401a6397e893808309ec374f5d8f890144906
    Author:     Joren De Cuyper <jorendc@libreoffice.org>
    AuthorDate: Tue Jul 22 13:19:42 2014 +0200
    Commit:     Tomaž Vajngerl <quikee@gmail.com>
    CommitDate: Tue Jul 22 11:38:56 2014 +0000
    
        Revert "fdo#74743 avoid infinite loop when gathering "svg" element styles"
    
        This reverts commit 3b7472b284131c09d91b69f26d5d26d54648f939.
        Commit 0879a639bc7c734f0847f74b965809f9107b3195 didn't
        revert all changes, so we ran into problems getting the
        css style correctly.
    
        Conflicts:
        	svgio/source/svgreader/svgstyleattributes.cxx
        	svgio/source/svgreader/svgsvgnode.cxx
    
        Change-Id: I4d17c6d599482de005c009638d03ca851491f700
        Reviewed-on: https://gerrit.libreoffice.org/10455
        Reviewed-by: Tomaž Vajngerl <quikee@gmail.com>
        Tested-by: Tomaž Vajngerl <quikee@gmail.com>

:100644 100644 272600d0e85498c737baddbaf40a4e14141aea8d b391ec5c393bfbdebe23856804c8800dde651c47 M	ccache.log
:100644 100644 468778775c02e9286e82bd619d9261a47ce162a3 9a64b0cd10a8cc4dee22c0e39c09d021785b4ae4 M	commitmsg
:100644 100644 4272548f1ec9e091afbab383be07dd3f21c4b619 8a01c44c0f06098104f46919f6aa96bac40b68fc M	make.log
:040000 040000 adfc2c90a8ee6756558b2c6cc9397236e1abecb3 1675303dcebc64f8a6f1aa07ad912cbe1e89c502 M	opt
Comment 7 Matthew Francis 2015-01-23 16:06:25 UTC
The behaviour changed as of the below commit.

Adding Cc: to l.lunak@collabora.com. Could you possibly take a look at this? Thanks


commit c5ed52b1cd6f22787c94bec035ceecf9e1da3271
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Mon Jul 21 10:56:52 2014 +0200

    ww8import create a pagedesc if continuous section changes margins (bnc#875383)
    
    This is similar to what writerfilter does. MSWord can have one page with several
    different margins, which are saved using continuous sections, which causes all
    kinds of trouble, because either we treat them as Writer sections, which means
    we lose some of the data, or we treat them as Writer page styles, which causes
    spurious page breaks if in the wrong place. Either option has its problems, but
    here it seems slightly better to go for keeping the data and hoping the page
    break will be in a place where a break will be anyway.
    
    Change-Id: I8f52aa820750da6788ea04180a15ac334f6bf87b
Comment 8 Timur 2015-10-06 12:09:06 UTC
Looks like duplicate of Bug 86468, same problem, same version.
Lubos added as CC in both bugs, but he doesn't seem to respond.

*** This bug has been marked as a duplicate of bug 86468 ***
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:19 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]