Bug 88709 - Allow Multiple References to Same Footnote
Summary: Allow Multiple References to Same Footnote
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2015-01-22 15:11 UTC by Daniel Grigoras
Modified: 2017-06-06 08:26 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2015-01-22 15:11:01 UTC
Hi,

I inserted a footnote with a character numbering and each time I copied the footnote reference to add it to the other lines of text that had to have the same footnote explanation, the footnote was multiplied three time with the same numbering and the same content.
I had to use a fake footnote reference as a workaround, i.e. a superscript character.
Comment 1 A (Andy) 2015-01-23 21:42:13 UTC
For me not reproducible with LO 4.3.5.2, Win 8.1.
Did you the same steps as I?  Which operating are you using?

Steps Done:
1. Open WRITER
2. Write two lines of text
3. Insert a footnote to line 1 (put the cursor there and go to INSERT -> FOOTNOTE/ENDNOTE, select CHARACTER in the NUMBERING section and select a character and press OK)
4. Select the superscripted footnote character and copy it with CTRL+C
5. Go to the second line and press CTRL+V to insert the copied footnote

Result: The footnote is copied as expected.
Comment 2 Joe P. 2015-01-24 02:04:00 UTC
Darius and Andy:

I have been able to reproduce this bug using the steps that Andy described. Each time I paste the footnote, copied from the first line, it made a duplicate of the actual footnote. My documented ended up looking like (the numbers on the end are superscript:

Line 1 of Text1
Line 2 of Text1
Line 3 of Text1

Line 4 of Text2
Line 5 of Text2



_________________
1 Foot Note
1 Foot Note
1 Foot Note
2 Foot Note 2
2 Foot Note 2


I performed 4.3.5.2 OS X 10.10.1. I was also able to reproduce this on 3.3.0 so it's probably been around for some time. I think we can move this to 'NEW' but since Andy didn't see it, I'll wait to see if anyone else can reproduce this.
Comment 3 Joel Madero 2015-01-24 03:55:04 UTC
I confirmed this following Andy's steps but with one change:

1. Open WRITER
2. Write two lines of text
3. Insert a footnote to line 1 (put the cursor there and go to INSERT -> FOOTNOTE/ENDNOTE, select CHARACTER in the NUMBERING section and select a character and press OK)

-Actually type some content into the inserted footnote (in the bottom of the page)

4. Select the superscripted footnote character and copy it with CTRL+C
5. Go to the second line and press CTRL+V to insert the copied footnote

Seems like what the user wants is to be able to reference that footnote again elsewhere without it pasting a new footnote entry (with the exact same content). So you could have ten different sentences referencing the same footnote.

This is an enhancement request, marking as such and updating title.

Darius - if you know of documentation that says it should behave differently (or if it behaved differently in the past) please leave a comment saying as much.

LibreOffice 4.4 rc1
Ubuntu 14.04 x64
Comment 4 Joel Madero 2015-01-24 04:12:09 UTC
MSO 2010 in W7 has the same behavior
Comment 5 Joe P. 2015-01-24 04:19:49 UTC
I would like to add that I was able to get the behavior that Darius was probably expecting by changing to superscript at the end of a sentence and select the duplicate foot note through the cross-reference dialog box.
Comment 6 Joel Madero 2015-01-24 04:20:13 UTC
Sorry for the noise but requesting UX to let us know how this should behave. Apparently using cross-references in a certain way allows you to achieve the desired behavior
Comment 7 Heiko Tietze 2015-01-24 10:19:26 UTC
Some time ago I faced the problem as well and solved it with fake footnotes. But cross-referencing is in fact the best solution. When pasting a footnote you could internally insert the reference and superscript the text. Makes sense for usability POV because the normal incrementing is not broken in this way.
But in my 4.3 installation this reference is not updated if I add another footnote before the referenced (e.g."He heard quiet steps1 behind him2. That didn't bode1 well." The last 1 is a (working) link to footnote 2). Update fields (F9) does not help, page preview is the same.
And when I remove the footnote its reference needs to be cleared. Otherwise I get an "Error: Reference source not found". So putting all together I would say we need a new type of reference (or special treatment for refs to footnotes).
Comment 8 Frank 2015-07-08 20:37:23 UTC
I also use the cross reference to make additional references to the same footnote, but haven't experienced any problems having it update when other footnotes are inserted prior.

But, I sure like Heiko Tietze's suggestion to have special treatment for footnote cross references. I suspect all it would need to do is automatically use the current character style for footnote references when such a cross reference was made, or at least offer that as a default and permit Ctrl+Z (or whatever is used for undo) to turn it back into a regular reference.

That would save a lot of tedious formatting ...

Frank
Comment 9 Robinson Tryon (qubit) 2016-08-25 05:39:01 UTC Comment hidden (obsolete)
Comment 10 Dieter Praas 2017-06-06 06:12:38 UTC
I cant reproduce it with LO 5.3.4.1. Everything works fine. So the problem has been solved?
Comment 11 Daniel Grigoras 2017-06-06 07:53:18 UTC
This is solved by just inserting a cross-reference to the footnote in question.
Comment 12 Cor Nouws 2017-06-06 08:26:21 UTC
thanks Daniel. We set as WorksForMe in a case like this, where there is no code commit/fix involved.