Bug Hunting Session
Bug 88736 - EDITING Edit > When "Select All" a document that contains both graphic or picture
Summary: EDITING Edit > When "Select All" a document that contains both graphic or pic...
Status: RESOLVED DUPLICATE of bug 87894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-23 09:14 UTC by cao momo
Modified: 2015-05-12 00:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test1 (17.41 KB, application/vnd.oasis.opendocument.text)
2015-01-23 09:15 UTC, cao momo
Details
test2 (18.45 KB, application/vnd.oasis.opendocument.text)
2015-01-23 09:15 UTC, cao momo
Details
test3 (30.87 KB, application/vnd.oasis.opendocument.text)
2015-01-23 09:16 UTC, cao momo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cao momo 2015-01-23 09:14:33 UTC
Shapes or pictures are not selected(Copy, Paste, Delete) When you Select All a document that contains both graphic or picture.

test1.odt : Shapes or pictures are not selected(Copy, Paste, Delete) When "Select All".
test2.odt :  Shapes or pictures are not selected(Copy, Paste, Delete) When "Select All".
test3.odt : Shapes or pictures anchored to page are not selected(Copy, Paste, Delete) When "Select All".
Comment 1 cao momo 2015-01-23 09:15:24 UTC
Created attachment 112702 [details]
test1
Comment 2 cao momo 2015-01-23 09:15:49 UTC
Created attachment 112703 [details]
test2
Comment 3 cao momo 2015-01-23 09:16:12 UTC
Created attachment 112704 [details]
test3
Comment 4 Joe P. 2015-01-24 02:56:42 UTC
I can confirm that there does appear to be a problem with this but the behavior seems odder than described. text1.odt and text2.odt behave as described by the submitter. For test3.odt I am getting all of the text and two of the objects from the select all.

In addition, I've observed the following behavior with test3.odt. When I select all and cut from the document it cuts the text and one of the objects in the document. Another object moves up the page and two others appear not to move at all. The behavior should have been that they all are removed with a cut. 

Second, with the test3.doc when I select all and paste in a new document all the text and two of the objects are pasted in the new document. When I select 'Undo' it removes the text and one object while another object remains.

This is almost certainly a bug but it might be reasonable that this is split up into two bugs. Any thoughts?
Comment 5 cao momo 2015-01-24 08:55:39 UTC
(In reply to cao momo from comment #0)
> Shapes or pictures are not selected(Copy, Paste, Delete) When you Select All
> a document that contains both graphic or picture.
> 
> test1.odt : Shapes or pictures are not selected(Copy, Paste, Delete) When
> "Select All".
> test2.odt :  Shapes or pictures anchored to last Line are not selected(Copy, Paste, Delete) When
> "Select All".
> test3.odt : Shapes or pictures anchored to page are not selected(Copy,
> Paste, Delete) When "Select All".
Comment 6 Gordo 2015-05-12 00:15:34 UTC

*** This bug has been marked as a duplicate of bug 87894 ***