Bug 88801 - Android: Can't load flat ODF
Summary: Android: Can't load flat ODF
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.1.0
Keywords: filter:fodt
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-01-26 09:42 UTC by Miklos Vajna
Modified: 2016-09-19 14:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2015-01-26 09:42:26 UTC
Currently the flat license button in the about dialog of the Android app loads a plain text version of the license, as we have plain text and flat ODF in git, and flat ODF is *also* opened as plain text, as in showing the raw XML markup instaed of some nicely formatted document.

It would be great to track down why flat ODF doesn't work in the Android app, then we could start shipping the flat ODF version of the license document instead.
Comment 1 Robinson Tryon (qubit) 2015-01-26 12:54:47 UTC
TESTING with Android 4.4.4 +

LibreOffice 4.5.0.0.alpha0+ Master
tinderbox: buildname: Android-ARM@24-Bytemark-Hosting
tinderbox: tree: MASTER
tinderbox: pull time 2015-01-26 04:29:24
tinderbox: git sha1s
core:4735ad02167576036c9f3c9dffb3ccbd0a884db7

(In reply to Miklos Vajna from comment #0)
> Currently the flat license button in the about dialog of the Android app
> loads a plain text version of the license, as we have plain text and flat
> ODF in git, and flat ODF is *also* opened as plain text, as in showing the
> raw XML markup instaed of some nicely formatted document.

REPRO steps:
- Open LO on Android
- "three button thing" -> About -> Show License

PROBLEM: See XML markup

NOREPRO -- Looks okay to me. I just see a bunch of licenses in a monospace font.

> It would be great to track down why flat ODF doesn't work in the Android
> app, then we could start shipping the flat ODF version of the license
> document instead.
Comment 2 Robinson Tryon (qubit) 2015-01-26 17:10:47 UTC
(In reply to Robinson Tryon (qubit) from comment #1)
>

Using same setup to test.

> > It would be great to track down why flat ODF doesn't work in the Android
> > app, then we could start shipping the flat ODF version of the license
> > document instead.

Here's another FODT test file: attachment 111034 [details] (Bug 87483 - weird list behavior)

(I have trouble trying to download that file with Firefox or w/the default Android browser. Side-loading it from my laptop, the filetype isn't recognized in Android and associated with LibreOffice)

Because I can't manage to open an external FODT file at all, 
Status -> NEW
Comment 3 raal 2015-05-12 06:21:32 UTC
I can open .fodt file with actual Version: 5.0.0.0.alpha1+
Build ID: 4906ecb

Seems to be fixed.
Comment 4 Miklos Vajna 2015-10-01 19:36:30 UTC
Loading the .fodt version of attachement 117083 still fails for me.
Comment 5 Miklos Vajna 2015-10-01 19:37:31 UTC
I mean attachment 117083 [details].
Comment 6 Commit Notification 2015-10-02 07:11:04 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9aa6ec9bfaa3c76c291ab8ec9a1b87fb89b817e6

tdf#88801 android: add services needed to load flat ODF documents

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 raal 2015-10-04 12:08:06 UTC
Verified: Version: 5.1.0.0.alpha1+
Build ID: 329496c
Comment 8 Robinson Tryon (qubit) 2015-12-17 13:06:16 UTC Comment hidden (obsolete)