Bug 88805 - Search Usability: add highlights, add counter
Summary: Search Usability: add highlights, add counter
Status: RESOLVED DUPLICATE of bug 88489
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2015-01-26 12:21 UTC by qubodup
Modified: 2017-07-22 08:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description qubodup 2015-01-26 12:21:01 UTC
LibreOffice Calc is missing basic features of spreadsheet software:
1. Highlighting all search-query-matching cells. This exists when using "find all" but should be active when using regular search as well.
2. The number of matching cells should be shown and the number of the last found cells should be shown in the sequence of all matches. The string "i/n" should be shown next to the search input (last found was #i in the total number of n matches)
3. Workflow should not be interrupted by messages like
"LibreOffice Calc has searched to the end of the sheet. Do you want to continue at the beginning?" or "LibreOffice Calc has searched to the beginning of the sheet. Do you want to continue at the end?" by having a counter, this could be considered superfluous. Related: https://bugs.documentfoundation.org/show_bug.cgi?id=65097

This animated .gif shows differences in those features between calc and google docs: http://i.imgur.com/RyCM3BP.gif
Comment 1 raal 2015-01-28 08:07:50 UTC
UX team, please take a look.
Comment 2 Adolfo Jayme Barrientos 2015-06-07 00:17:45 UTC
The interruptions have been removed: http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=948d606b0260a33a5db77061f560afebde3fcdb7
Comment 3 Robinson Tryon (qubit) 2016-08-25 05:39:25 UTC Comment hidden (obsolete)
Comment 4 mahfiaz 2016-09-20 06:59:33 UTC
I would have filed it myself if it wasn't reported already. I wholeheartedly agree and miss this feature every time I search in Calc.
Comment 5 Heiko Tietze 2017-07-22 08:58:28 UTC
The request makes absolutely sense but I close it because it deals with more than one topic and we have other tickets that covers the ideas. There is  bug 88489 for #1 and bug 90451 for #2 - and #3 is solved according comment 2.

*** This bug has been marked as a duplicate of bug 88489 ***