Download it now!
Bug 88812 - FILEOPEN: Performance regression in speed of RTF import
Summary: FILEOPEN: Performance regression in speed of RTF import
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
PreBibisect
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.0.0
Keywords: filter:rtf, perf, preBibisect, regression
Depends on:
Blocks:
 
Reported: 2015-01-26 15:00 UTC by Matthew Francis
Modified: 2015-12-15 11:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-01-26 15:00:58 UTC
This is split from bug 58736.
Observed on OSX 10.10, LO 4.0.6.2 and later. Speed is good up to at least 3.4.6.2; releases after 3.4.6.2 and before 4.0.6.2 are slow but also hang at the end of the import.

Steps to reproduce:
1. Load the RTF file from attachment 82177 [details]

Expected result:
- File loads as quickly as in LO 3.3.0

Actual result:
- File loads much more slowly than in LO 3.3.0
Comment 1 Matthew Francis 2015-01-26 15:04:58 UTC
Looking past the fact that the file fails to finish loading in the early part of the 43all bibisect repo, the speed at which the import occurs (before the hang) suggests that this problem is pre-bibisect

Adjusting metadata to suit.
Comment 2 Joel Madero 2015-01-26 23:49:02 UTC
Setting version to preBibisect to match the whiteboard status
Comment 3 Joel Madero 2015-01-27 00:01:40 UTC
ubuntu 14.04 x64

Test Results*
4.4.0.2 rc
3:13.1

4.3.5.2 release
2:46

3.3
1:05


*Was building LibreOffice simultaneously so speeds probably were affected by this. None the less comparisons probably still valid.

Setting this to NEW as I can confirm there has been a steep decline in performance for this file. setting to:

Minor - slows down professional quality work but does not prevent it;
Medium - as this is a regression, bumped from low.
Comment 4 Yousuf Philips (jay) (retired) 2015-02-24 21:53:35 UTC
Hey Matthew,

This is likely because we changed the RTF import filter starting in 3.5. :D We moved from the one that came with AOO to the one Miklos created.
Comment 5 Miklos Vajna 2015-03-06 14:16:00 UTC
Do you have some concrete numbers on how much time it took to import the document in 3.3 and how much time is required currently?
Comment 6 Miklos Vajna 2015-03-06 14:17:33 UTC
Ah sorry, forgot to read all comments. ;-) I'll try to run the document in callgrind and see if anything pops out.
Comment 7 Commit Notification 2015-04-08 18:40:24 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b23d55ccc24a37c60d39061a4e497181b9609e9b

tdf#88812 sw: speed up SwDoc::MakeFlyAndMove()

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Miklos Vajna 2015-04-08 19:06:54 UTC
0m46.833s -> 0m26.832s is hopefully enough to get this marked as resolved. ;-)
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:30:56 UTC
Migrating Whiteboard tags to Keywords: (perf preBibisect filter:rtf)
removed extra rtf_filter
[NinjaEdit]