Bug 88841 - VIEWING: PowerPoint Textbox not Displayed in Linux
Summary: VIEWING: PowerPoint Textbox not Displayed in Linux
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: mab5.0
  Show dependency treegraph
 
Reported: 2015-01-28 02:57 UTC by Luke
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of text not displayed (94.50 KB, application/vnd.ms-powerpoint)
2015-01-28 02:58 UTC, Luke
Details
Comparison of Impress vs PowerPoint (167.42 KB, image/png)
2015-01-28 02:59 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-01-28 02:57:23 UTC
Steps to Reproduce
1. Create a PowerPoint 2013 presentation with a textbox
2. Save as .PPT
3. Open in a recent build of Impress under Linux

In Linux, Impress does not display any of the text. This regression appeared between 1/14-1/25

2015-01-14 Version: 4.5.0.0.alpha0+
Build ID: 8c291bb13335fc73785eab2bba81b37a5161d6b4
Good

2015-01-25 Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
BAD
Comment 1 Luke 2015-01-28 02:58:32 UTC
Created attachment 112847 [details]
Example of text not displayed
Comment 2 Luke 2015-01-28 02:59:30 UTC
Created attachment 112848 [details]
Comparison of Impress vs PowerPoint
Comment 3 Buovjaga 2015-01-29 20:33:13 UTC
Confirmed.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-25_23:58:40
Comment 4 Buovjaga 2015-01-29 20:33:58 UTC
Why the heck did I not change to NEW, then :D
Comment 5 Michael Weghorn 2015-01-30 22:27:38 UTC
bibisect result:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
4d22346f21b8f6b6346180e1a3a06f706e0f33b2
5ba09ea49b58847a32576bcd4ff266255852439d
We cannot bisect more!

-------

$ git bisect log
# bad: [fd2aac6a4fa18f8409c13d8e3747575d083137e9] 2015-01-30: source-hash-309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83
# good: [e4b0a61cedc6ac0e65a4a110fd83edd8295f4856] 2014-11-20: source-hash-d273a60bfdbf9bb7623bed38667ec0647753157c
git bisect start 'master' 'oldest'
# good: [999985618920182fcb30d26efda3d62db39a357d] 2014-12-25: source-hash-e3663390d351c3759c22ae5a4fc44fd869c4479f
git bisect good 999985618920182fcb30d26efda3d62db39a357d
# good: [0efe6a282f351872bc70b122c4b4b1104519f1d3] 2015-01-12: source-hash-7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
git bisect good 0efe6a282f351872bc70b122c4b4b1104519f1d3
# bad: [70786150cf29ba9abe1b7bb6332aa55463ed865e] 2015-01-21: source-hash-60143f4f7bc50054dcef923218b8c7c3bc154933
git bisect bad 70786150cf29ba9abe1b7bb6332aa55463ed865e
# good: [636737e0bca8097f74b6da3fbf4136375d64a0b7] 2015-01-16: source-hash-4c93c341be1425401112eed3581e8b8a6308880d
git bisect good 636737e0bca8097f74b6da3fbf4136375d64a0b7
# good: [bbd7dd4d7f4cadf0608151941d510b4a54e356dc] 2015-01-18: source-hash-15db0307fe6429238be72612cccd4a1df5e1e97c
git bisect good bbd7dd4d7f4cadf0608151941d510b4a54e356dc
# bad: [5ba09ea49b58847a32576bcd4ff266255852439d] 2015-01-20: source-hash-b5fab0c20550b724986ad8a59973b92b181e0478
git bisect bad 5ba09ea49b58847a32576bcd4ff266255852439d
# skip: [4d22346f21b8f6b6346180e1a3a06f706e0f33b2] 2015-01-19: source-hash-f9bea19eeab49cb9e6fcdd3ae5e777da9dc882ca
git bisect skip 4d22346f21b8f6b6346180e1a3a06f706e0f33b2
# only skipped commits left to test
# possible first bad commit: [5ba09ea49b58847a32576bcd4ff266255852439d] 2015-01-20: source-hash-b5fab0c20550b724986ad8a59973b92b181e0478
# possible first bad commit: [4d22346f21b8f6b6346180e1a3a06f706e0f33b2] 2015-01-19: source-hash-f9bea19eeab49cb9e6fcdd3ae5e777da9dc882ca



Unfortunately I had to "git bisect skip" the last step because LO crashed with the following message when opening the file:

soffice.bin: /home/vmiklos/git/libreoffice/master/include/tools/helpers.hxx:29: typename boost::enable_if<boost::mpl::or_<boost::is_signed<T>, boost::is_floating_point<T> >, long int>::type MinMax(T, long int, long int) [with T = long int; typename boost::enable_if<boost::mpl::or_<boost::is_signed<T>, boost::is_floating_point<T> >, long int>::type = long int]: Assertion `nMin <= nMax' failed.


Note however, that LibreOffice does start if I do not open that file - maybe that also has to do with the bug. (?)
Comment 6 Matthew Francis 2015-01-31 02:06:04 UTC
The text became invisible as of the below commit.

Adding Cc: to quikee@gmail.com; Could you possibly take a look at this? Thanks


d53103dd83bf20ac63485e229069f145e35b3009 is the first bad commit
commit d53103dd83bf20ac63485e229069f145e35b3009
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Sun Jan 18 23:51:14 2015 +0900

    fdo#74124 bilinear scaling with blending for some formats
    
    The DrawDeviceAlphaBitmapSlowPath used fast/ugly scaling with
    blending. With this a bilinear scaling is used which should
    improve quality for downscaling (less than 50% should start to
    degrade in quality as only 2 samples are always used) and
    upscaling.
    
    Change-Id: I56cdf2b5761687be891387343a773b6fefac03e2
Comment 7 Matthew Francis 2015-02-15 12:47:50 UTC
Fixed in the below commit on master.


commit 4bf97acefcf88c1e5a7d7722d72a5b0d7995ee3d
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Thu Feb 12 13:55:24 2015 +0100

    do not silently fail if the optimized blend path doesn't do anything
    
    Otherwise e.g. rotated images in Draw may show as empty. Broken in d53103dd83bf20ac.
    
    Change-Id: I0b99b6c39b96f87a78ccb09c9db0a1bfac0f3296
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:05 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]