Download it now!
Bug 88856 - CRASH: placeholder currency variable field
Summary: CRASH: placeholder currency variable field
Status: RESOLVED DUPLICATE of bug 82942
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
: 88857 88889 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-28 15:20 UTC by Marina Latini (SUSE)
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
affected file (8.17 KB, application/vnd.oasis.opendocument.text)
2015-01-28 15:20 UTC, Marina Latini (SUSE)
Details
Crash on double click backtrace.txt (37.14 KB, text/plain)
2015-01-28 18:08 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2015-01-28 15:20:21 UTC
Document with currency variable field generated with 
Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-25_23:58:40
Locale: it_IT
OS: Ubuntu 14.04.1 LTS x86_64

Steps to reproduce:

1. Open the odt file
2. Double click on the field
3. Click ok -> LibreOffice crashes


OR
a) Open a new writer document
b) Menu Insert-> Fields-> More Fields…
c) Variables
d) click on "set variable"
e) type a name
f) from "format" click on "additional formats..."
g) Select the "currency" category
h) Choose the "Format" EUR € Italian (Italy) 
i) On Language choose "automatic language"
j) Insert the new field
k) On "Type" click on "input field"
l) Select the field created with the previous steps
m) Select the right format (from steps f to I)
n) click on "insert"
o) ok
p) click "close"
q) save the file and close
r) reopen the file
s) double click on the field
t) click ok -> LibreOffice crashes
Comment 1 Marina Latini (SUSE) 2015-01-28 16:27:11 UTC
*** Bug 88889 has been marked as a duplicate of this bug. ***
Comment 2 Marina Latini (SUSE) 2015-01-28 16:28:04 UTC
*** Bug 88857 has been marked as a duplicate of this bug. ***
Comment 3 Timur 2015-01-28 17:39:34 UTC
Using the file attached, bug reproduced on Windows starting with LO 4.4.0.3., so I mark as a regression. For some reason, WinDBG busy, so no backtrace now.

Steps to reproduce:
1. Open the affected odt file
2. Double click on the field and click OK
3. On closing, with file either saved or not, LibreOffice crashes
Comment 4 Timur 2015-01-28 18:08:41 UTC
Created attachment 112898 [details]
Crash on double click backtrace.txt
Comment 5 Matthew Francis 2015-01-29 03:05:34 UTC
Bibisect results from 44:
(Note: caution required in reproduction. It's not quite as reliably reproducible as it first appears)

2f84e5da87db237dc045e9a232a35513d3297a7e is the first bad commit
commit 2f84e5da87db237dc045e9a232a35513d3297a7e
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sat Oct 18 23:57:31 2014 +0000

    source-hash-d718c1f65f850f7897b942c2e4415110132e51a5
    
    commit d718c1f65f850f7897b942c2e4415110132e51a5

# bad: [4a3091e95fa263d3e2dd81e56e83996f0bb12287] source-hash-2b5b04e1e62914bf0902dfd7943cdc44499c47a6
# good: [812c4a492375ac47b3557fbb32f5637fc89d60d9] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect start 'latest' 'oldest'
# good: [5d0dfb8e62ae61a240f8313c594d4560e7c8e048] source-hash-0c6cd530de13f80795881f61064f1bf1dcc4ea81
git bisect good 5d0dfb8e62ae61a240f8313c594d4560e7c8e048
# bad: [7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5] source-hash-f93ce4f7eb90093d0ea3115d0a1c614612676dbd
git bisect bad 7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5
# good: [1a63057f6378db7c6b8af1171b7b140f7583f246] source-hash-59f84b4a2c082382767f12e0c7a06a3f0b52e721
git bisect good 1a63057f6378db7c6b8af1171b7b140f7583f246
# good: [2fdc98d4cfbffea5b33224bd2106aeb3b74b84a7] source-hash-d4a8fa7db0ed4faae00408fbda2352379774cfc0
git bisect good 2fdc98d4cfbffea5b33224bd2106aeb3b74b84a7
# bad: [3ff4aa6b7f147a98388d57e35368311034bceab6] source-hash-35e260c4a3e886c4177b232871f9f2775cd5c5f5
git bisect bad 3ff4aa6b7f147a98388d57e35368311034bceab6
# bad: [67b357d7f313d5ff960b6cf6646053b11e04ef7c] source-hash-bf640ba048704220292411e4f2bcc0d3c62caa32
git bisect bad 67b357d7f313d5ff960b6cf6646053b11e04ef7c
# good: [15089b6fcec017844895bab1dc9524cd904fe116] source-hash-be1bb7b1ccee28be616b89cc95e97d656e78bbe3
git bisect good 15089b6fcec017844895bab1dc9524cd904fe116
# bad: [2f84e5da87db237dc045e9a232a35513d3297a7e] source-hash-d718c1f65f850f7897b942c2e4415110132e51a5
git bisect bad 2f84e5da87db237dc045e9a232a35513d3297a7e
# good: [2025ac4bff9db6fbf8e1af8a66655bca5489a449] source-hash-a6c5f2ba6bca8ad95a3731e2770a1d216c9925a0
git bisect good 2025ac4bff9db6fbf8e1af8a66655bca5489a449
# first bad commit: [2f84e5da87db237dc045e9a232a35513d3297a7e] source-hash-d718c1f65f850f7897b942c2e4415110132e51a5
Comment 6 Matthew Francis 2015-01-29 04:06:40 UTC
The crash appears to have started with the below commit

Adding Cc: to mstahl@redhat.com; Could you possibly take a look at this? Thanks


commit eee8b6eed6145f695d532aa62c33e3a0c44cba86
Author: Michael Stahl <mstahl@redhat.com>
Date:   Wed Aug 20 12:56:12 2014 +0200

    SwWrtShell::StartInputFldDlg() can be called with RES_SETEXPFLD too
    
    ... and there's no way to get the SwFmtFld from a SwSetExpField, so add
    a member for it like SwInputField has.  That's still better than the
    UnoCallBack nonsense.
    
    Change-Id: I59c82e95414dbae284432b8a318a6ce1a34256c7
Comment 7 Matthew Francis 2015-01-29 04:08:49 UTC
... this time actually adding the Cc: to mstahl@redhat.com

This seems to relate to the above mentioned commit eee8b6eed6145f695d532aa62c33e3a0c44cba86. Could you possibly take a look? Thanks
Comment 8 Caolán McNamara 2015-02-04 12:04:09 UTC

*** This bug has been marked as a duplicate of bug 82942 ***
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:12 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]