Bug 88899 - Libre Office Writer does not show Time of Custom Properties with Type: DateTime
Summary: Libre Office Writer does not show Time of Custom Properties with Type: DateTime
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.5.0 target:4.4.1 target:4.3....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-01-29 11:59 UTC by Wolfgang Kleinoeder
Modified: 2016-10-25 19:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
contains attachments mentioned in description (124.12 KB, application/pdf)
2015-01-29 11:59 UTC, Wolfgang Kleinoeder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Kleinoeder 2015-01-29 11:59:25 UTC
Created attachment 112910 [details]
contains attachments mentioned in description

takes less than 30 seconds to reproduce it

Libre Office Writer v4.4.0.2
Windows 7 Professional Service Pack 1

Bug 29.01.15 11:50:   29.01.15 00:00   ← should be 11:50

Here is how to reproduce:
File → Properties → Custom Properties (cf. Appendix 1)
	Type: DateTime   Value: 29.01.15 11:50

Insert → Fields → More Fields → 
	Custom → bug 150129 1150 → Format: 31.12.99 → Insert   (OK)
	Custom → bug 150129 1150 → Format: 13:37 (expected: 11:50) → Insert   (not OK)
			(cf. Appendix 2)
Comment 1 Buovjaga 2015-01-31 12:02:28 UTC
Reproduced in >= 4.3.3.2.
NOT reproduced in 3.5.0.

Note for bibisecters: instructions are in the pdf pages 2 & 3, just try inserting the 13:37 format.

"Not OK" means that it inserts 00:00 instead of the values you gave to your custom property.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-29_23:44:46

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8fd9c25ac66dd238d4c68be3974241a18cb21705
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-27_22:43:15

and

Version: 4.3.3.2
Build ID: 430m0(Build:2)

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 tmacalp 2015-02-01 01:27:25 UTC
Bisected:

a58547d361d33ffd0c076cb8c6a531bd6da277a9 is the first bad commit
commit a58547d361d33ffd0c076cb8c6a531bd6da277a9
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 00:54:38 2013 +0000

    source-hash-d62425cc27e04a3237cfec2ea2663b8b11284ec8
    
    commit d62425cc27e04a3237cfec2ea2663b8b11284ec8
    Author:     Noel Grandin <noel@peralex.com>
    AuthorDate: Wed Apr 17 13:54:28 2013 +0200
    Commit:     Fridrich Strba <fridrich@documentfoundation.org>
    CommitDate: Fri Apr 19 07:51:41 2013 +0000
    
        Java cleanup, remove unnecessary casts
    
        Change-Id: Id12089bc7df16631737e6acaee0973fb91dd953f
        Reviewed-on: https://gerrit.libreoffice.org/3431
        Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org>
        Tested-by: Fridrich Strba <fridrich@documentfoundation.org>

$ git bisect log
git bisect start 'last41onmaster' 'last40onmaster'
# good: [c1631ee90606d0a7928496fb9548bcd0dbe69dbf] source-hash-28fb57daa77438f5e63132d3417062a11a44461e
git bisect good c1631ee90606d0a7928496fb9548bcd0dbe69dbf
# good: [0e1044821fb18012f74e2c8fd79abba13944ac9d] source-hash-11b851d2f2f8ee6230b8c732d5b157e472c21be2
git bisect good 0e1044821fb18012f74e2c8fd79abba13944ac9d
# bad: [7130a0223e15d56e6ec1f0b6bb08e0793729cb4a] source-hash-eea39218ca7c22e40b997b5efd0d9ea08e01090b
git bisect bad 7130a0223e15d56e6ec1f0b6bb08e0793729cb4a
# bad: [e86a4dee1ed62ca57727ad50308504362b68b135] source-hash-f62a00f32a1adb4052b05e406cb0e040c7f2360d
git bisect bad e86a4dee1ed62ca57727ad50308504362b68b135
# bad: [013adf05b6bf8e5d44a4e820d43177d7fb749079] source-hash-a16a4006e40bdb2cb4671846295fe2bf5a856e68
git bisect bad 013adf05b6bf8e5d44a4e820d43177d7fb749079
# bad: [5382b86116ba1fa6ef93a0aeb810a66ef3aa2a78] source-hash-609cb4b332e4b2ddb1f449ba059fd33c3d49dc84
git bisect bad 5382b86116ba1fa6ef93a0aeb810a66ef3aa2a78
# bad: [a58547d361d33ffd0c076cb8c6a531bd6da277a9] source-hash-d62425cc27e04a3237cfec2ea2663b8b11284ec8
git bisect bad a58547d361d33ffd0c076cb8c6a531bd6da277a9
# first bad commit: [a58547d361d33ffd0c076cb8c6a531bd6da277a9] source-hash-d62425cc27e04a3237cfec2ea2663b8b11284ec8
Comment 3 Matthew Francis 2015-02-01 14:25:26 UTC
The behaviour seems to have changed as of the below commit.
(The build is broken for several following commits, but by 824caac79d983ad1aa93a6ec51558d7edb6f2a7d when it is fixed, the problem is already visible)

Adding Cc: to lionel@mamane.lu; Could you possible take a look at this? Thanks


commit 9830fd36dbdb72c79703b0c61efc027fba793c5a
Author: Lionel Elie Mamane <lionel@mamane.lu>
Date:   Sun Mar 17 08:36:26 2013 +0100

    date/time IDL datatypes incompatible change
    
     - nanosecond precision
     - signed (allowed negative) year
    
    Also: assorted improvements / bugfixes in date/time handling code.
    Some factorisation of copy/pasted code.
    
    Change-Id: I761a1b0b8731c82f19a0c37acbcf43d3c06d6cd6
Comment 5 Commit Notification 2015-07-07 13:42:00 UTC
Varun committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecbe2ef3c7bf561b18988ef0a5764e48923d767f

Add Test for tdf#88899 SwDocInfoField with DateTime

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Robinson Tryon (qubit) 2015-12-17 08:45:36 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]