Bug 88920 - "Edit Style" in context menu is a confusing name
Summary: "Edit Style" in context menu is a confusing name
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2015-01-30 04:35 UTC by evaned
Modified: 2018-12-20 16:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description evaned 2015-01-30 04:35:57 UTC
1. Create a new presentation
2. Draw two+ shapes (rectangle, circle, etc.) on the slide
3. Right click on one of them -> "Edit Style"
4. Don't notice the title bar says "Default" in it
5. Change something, e.g. "Area" and pick a color

Expected: the background of the shape you clicked on changes
Actual: the backgrounds of all shapes change

I suggest something like "Edit default style" for the context menu or something like that.

(I realize that there's an "Area" entry in the context menu, but when I was looking for how to change the background color I saw Edit Style first and clicked to see if it was in there.)

This bug would be a lot more minor if it weren't for the fact that you can't undo the change in step 5, which I will be filing another bug for presently.
Comment 1 A (Andy) 2015-01-31 10:17:07 UTC
Reproducible with LO 4.4.0.3, Win 8.1.

I agree it would be good to make it more clear what EDIT STYLE means, that new users are not confused.  
Maybe the suggestion from the Description with "Edit default style" is already a good proposal.  For me it sounds very good.
Comment 2 Cor Nouws 2015-02-03 10:45:31 UTC
Good idea. thanks.
What about maybe "Edit style Default"
Comment 3 Thomas Lendo 2018-10-29 12:11:27 UTC
To be sure I add keyword needsUXEval to discuss this with the broader UX team.
Comment 4 Heiko Tietze 2018-12-17 14:40:00 UTC
"Edit _default_ style" doesn't work for other styles like "Filled Blue" (and the actual style name is shown in the dialog caption). Is the command/label really so uncommon that we need to device from Writer? Wouldn't say so.
Comment 5 andreas_k 2018-12-18 13:52:05 UTC
Edit Style edit the actual style but it would be awesome to get styles support in sd (impress and draw) like in writer where you can add different styles via context menu.

The problem is, that you can't have usefull predefined styles in draw/writer the styles for context menu should be dynamic (show used styles in an selection list and edit style for edit the existing style)

For me Edit styles is in draw and impress very confusing as well, but I don't think renaming would be the solution. I suggest to have the layout like in writer where you have defined styles via context menu, menubar, ...
Comment 6 Heiko Tietze 2018-12-18 15:01:54 UTC
(In reply to andreas_k from comment #5)
> Edit Style edit the actual style but it would be awesome to get styles
> support in sd...

Different topic. You have Drawing Styles right now and that's what you modify with "Edit Style" where the request here is to make it more clear on what style it is effective.
Comment 7 Heiko Tietze 2018-12-20 16:19:02 UTC
We talked about this in the design meeting and agree on WF. "Edit Style" is used across the modules for changing the object's style. The confusion in this case comes likely from the fact that shapes have a drawing style, which is changed with this command.