Download it now!
Bug 88925 - svg IMPORT of rotated line/text broken
Summary: svg IMPORT of rotated line/text broken
Status: RESOLVED DUPLICATE of bug 57215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0 target:4.4.5
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2015-01-30 07:38 UTC by klaus.welch
Modified: 2015-12-17 06:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
full testcase to reproduce svn import issue (152.38 KB, application/zip)
2015-01-30 07:38 UTC, klaus.welch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description klaus.welch 2015-01-30 07:38:35 UTC
Created attachment 112940 [details]
full testcase to reproduce svn import issue

Hello LibreOffice team,

what we regularly do for technical documentation:
 * create drawings (block diagrams,...) with sdraw
 * export drawings to svg
 * create documents with swriter
 * import drawing in swriter (Insert->Image...)

Even if drawing contains rotated lines/text it:
 * looks ok in sdraw
 * exports to correct looking pdf (from sdraw)
 * exports to correct looking svg (checked with gimp and eog)

That good looking svg IMPORTED into swriter is displayed wrong, rotation is missing. 
Svgs not containing rotation are displayed correctly.

For those drawings we have to fall-back to wmf as exchange format between sdraw and swriter.

There are some bugs filed/resolved looking similar but they all refer to wrong svn export. 
This issue is about svg IMPORT.

A testcase is appended.

Even the latest version 4.4.0.3 is affected.
The issue is persistent since several releases. Don't know since when.

Best regards,

Klaus Welch
Comment 1 V Stuart Foote 2015-01-30 14:37:51 UTC
Confirming .SVG issues on import of rotated text. 

But actually there are also issues with the text if import either .EMF or .WMF vector renderings of the test case .ODG.

Fortunately a functional workaround is done with Insert -> Object -> OLE Object, use the "Create from file" radio button and search locate the file. You can "Link to file" for updates, but I prefer to keep things clean with just the copy.

You will get a clean rendering of the .ODG and text in Writer, but the Writer file will be larger--for now have to choose function or size.
Comment 2 klaus.welch 2015-05-29 08:22:48 UTC
Hello LibreOffice team,

the recommended workaround is not functional (at least for me).

I neither managed to scale an OLEed drawing in the containing master-document
nor showing just a part of a drawing nor selecting a specific page of 
a multi-page drawing.

This bug is really annoying. 

I do not ask for fixing import of proprietary formats like wmf/emf.

Please fix the svg import as svg is an open and well documented standard format.

Best regards,

Klaus Welch
Comment 3 V Stuart Foote 2015-05-29 15:21:01 UTC
(In reply to klaus.welch from comment #2)
> 
> I do not ask for fixing import of proprietary formats like wmf/emf.
> 
> Please fix the svg import as svg is an open and well documented standard
> format.

This has already been corrected for 5.0.0beta1, and current master. Please retest generating all elements of test kit using a more current build.

*** This bug has been marked as a duplicate of bug 57215 ***
Comment 4 klaus.welch 2015-06-01 10:22:36 UTC
Hello LibreOffice team,

i've just installed LibreOfficeDev_5.0.0.0.beta1_Linux_x86-64 and tried my testcase.

I can confirm that my svg-import-issue is fixed :-)

Many thanks!

Best regards,

Klaus Welch

PS : Backport to 4.4.x would be great.
Comment 6 Robinson Tryon (qubit) 2015-12-17 06:33:49 UTC
Migrating Whiteboard tags to Keywords: (filter:svgInsert)
[NinjaEdit]