Download it now!
Bug 88945 - Argument separators of Calc functions are inconsistent in the UI and Help.
Summary: Argument separators of Calc functions are inconsistent in the UI and Help.
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 89166 98609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-30 15:03 UTC by Junichi Matsukawa
Modified: 2016-05-31 16:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
In the Function Wizard,If Function usage. (39.19 KB, image/png)
2015-01-30 15:03 UTC, Junichi Matsukawa
Details
In CALC Help,IF Function usage. (71.37 KB, image/png)
2015-01-30 15:05 UTC, Junichi Matsukawa
Details
english(US) UI IF function wizard (63.80 KB, image/png)
2015-05-29 08:51 UTC, Junichi Matsukawa
Details
english(US) UI-help IF function wizard (75.00 KB, image/png)
2015-05-29 08:52 UTC, Junichi Matsukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Junichi Matsukawa 2015-01-30 15:03:06 UTC
Created attachment 112958 [details]
In the Function Wizard,If Function usage.

In the function wizard,IF Function usage is  =IF(Logical expression,TRUE if,
FALSE if).
In CALC Help,IF Function usage is  =IF(Test;Thenvalue;OtherwiseValue).

I think I should be standardized to comma.

ex.1) Pootle 4.4Help.
https://translations.documentfoundation.org/ja/libo_help/translate/scalc/01.po#unit=30754190

IF(Test; ThenValue; OtherwiseValue)  --> IF(Test, ThenValue , OtherwiseValue)

ex.2) Pootle 4.4Help.
https://translations.documentfoundation.org/ja/libo_help/translate/scalc/01.po#unit=30756340

<item type="input">=IF(A1>5;100;"too small")</item> If the value in A1 is higher than 5, the value 100 is entered in the current cell; otherwise, the text “too small” (without quotes) is entered.

-->
<item type="input">=IF(A1>5,100,"too small")</item> If the value in A1 is higher than 5, the value 100 is entered in the current cell; otherwise, the text “too small” (without quotes) is entered.
Comment 1 Junichi Matsukawa 2015-01-30 15:05:15 UTC
Created attachment 112959 [details]
In CALC Help,IF Function usage.
Comment 2 Naruhiko Ogasawara 2015-02-02 04:07:58 UTC
air@kagaku.xii.jp,

Let me confirm, it's not only IF function description problem, but "ANY" calc functions have same policy-mismatching, so we need to change policy to use comma "," instead of semicolon (";") in HELP, right?
Comment 3 Junichi Matsukawa 2015-02-02 05:05:56 UTC
Hi. Naruhiko Ogasawara.

I think also "ANY" calc functions change policy to use comma "," instead of semicolon (";") in HELP.
Comment 4 Stanislav Horacek 2015-02-02 17:38:22 UTC
Is this report related to your localization only? In English locale, I see semicolons in both UI and help and I think they are correct as semicolon is the default argument separator in Calc.
Comment 5 Buovjaga 2015-02-06 16:28:55 UTC
NEEDINFO per comment 4.
Comment 6 Junichi Matsukawa 2015-05-29 08:46:05 UTC
I had to try it LBO5.0.0Beta1.

LibreOfficeDev_5.0.0.0.beta1_Win_x86.msi
LibreOfficeDev_5.0.0.0.beta1_Win_x86_helppack_en-US.msi
LibreOfficeDev_5.0.0.0.beta1_Win_x86_helppack_de.msi
LibreOfficeDev_5.0.0.0.beta1_Win_x86_helppack_fr.msi


(ex IF function wizard - and press 'HELP')
A.locate setting english(US)

 UI: if(Test,The_value,Otherwise_value) (comma)
 Help: Syntax IF(Test; ThenValue; OtherwiseValue) (semicolone)

*Description of Syntax does not match. alao japan.

B.locate setteing german

 UI: WENN( prufung; Dann_Wert; Sonst_Wert) (semicolone)
 Help: Syntax WENN(prufung; DannWert; SonstWert) (semicolone)

C.locate setteing France

 UI: SI(Test; Valeur;si_vrai;Valeur_si_faux) (semicolone)
 Help: SI(test;alors_baleur;sinon_baleur) (semicolone)
Comment 7 Junichi Matsukawa 2015-05-29 08:51:31 UTC
Created attachment 116126 [details]
english(US) UI IF function wizard
Comment 8 Junichi Matsukawa 2015-05-29 08:52:59 UTC
Created attachment 116127 [details]
english(US) UI-help IF function wizard
Comment 9 Stanislav Horacek 2015-05-29 09:42:29 UTC
OK, I see your point now. You are right that the default argument separator for English locale setting is comma, whereas syntaxes in English Help use semicolons. (So my previous comment was wrong.)

I guess there used to be semicolon as default for all locales (and the Help was written for it), but then it has been changed to comma in the English locale to correspond with Excel (?).

Anyway, in my opinion the change of help would be so huge and would have so bad side effects (need for translations) that it is not worth even think about it:))
Comment 10 QA Administrators 2015-12-27 20:31:16 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 11 Stanislav Horacek 2015-12-27 20:44:44 UTC
The bugreport is clarified now - set to NEW.
Changed summary to reflect that there is a general inconsistency in argument separators between UI and Help.

See also this related thread:
http://listarchives.libreoffice.org/global/documentation/msg18510.html
Comment 12 Stanislav Horacek 2016-03-12 18:01:43 UTC
*** Bug 98609 has been marked as a duplicate of this bug. ***
Comment 13 Eike Rathke 2016-05-31 15:49:59 UTC
*** Bug 89166 has been marked as a duplicate of this bug. ***
Comment 14 Eike Rathke 2016-05-31 16:06:24 UTC
The actual function parameter separator used depends on the locale and the settings under Tools-Options-Calc-Formula. However, the (default English) Calc help uses semicolon and that also works, regardless of which separator is actually set. Also, the help is not necessarily translated into all locales and a semicolon is much less confusing than any other separator. So rather stick with the semicolon in help than having examples that for some locales or settings don't work just because the help isn't translated. Letting the help reflect the actual separator used will likely not be implemented, specifically not with the help being also available as a wiki version.

I'm closing this as wontfix.