Bug 88976 - Justification problem with Persian (Farsi) script in LO Writer 4.4
Summary: Justification problem with Persian (Farsi) script in LO Writer 4.4
Status: RESOLVED DUPLICATE of bug 35320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-31 13:04 UTC by Hessam Shahpouri
Modified: 2015-02-03 13:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The PNG file that show the problem in LibreOffice Writer 4.4 (401.33 KB, image/png)
2015-01-31 13:04 UTC, Hessam Shahpouri
Details
The original ODF file contains paragraph (11.74 KB, application/vnd.oasis.opendocument.text)
2015-01-31 13:07 UTC, Hessam Shahpouri
Details
The generated PDF file from the ODF file using LibreOffice Writer 4.4 (13.92 KB, application/pdf)
2015-01-31 13:08 UTC, Hessam Shahpouri
Details
PDF export from 4.4.0.3 (14.28 KB, application/pdf)
2015-02-02 11:39 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hessam Shahpouri 2015-01-31 13:04:11 UTC
Created attachment 112989 [details]
The PNG file that show the problem in LibreOffice Writer 4.4

There is a major and annoying problem in LibreOffice Writer 4.4.0 with Persian scripts.

** How to produce it? **

Make the paragraph's direction "Right-To-Left" and set its "Alignment" to "Justified", then type some words in Persian script.
You'll see some letters in end of each line have extra tail that it's incorrect!

I attached an ODF, PDF and PNG files to explain it better.
I tested this with many number of fonts and problem exists yet.

I have to add "Kashida" to each line manually and it's very difficult for large documents. :-(

I'm using Unubtu 14.04 LTS on my laptop.
Comment 1 Hessam Shahpouri 2015-01-31 13:07:05 UTC
Created attachment 112990 [details]
The original ODF file contains paragraph
Comment 2 Hessam Shahpouri 2015-01-31 13:08:30 UTC
Created attachment 112991 [details]
The generated PDF file from the ODF file using LibreOffice Writer 4.4
Comment 3 Buovjaga 2015-02-02 11:39:14 UTC
Created attachment 113049 [details]
PDF export from 4.4.0.3

It seems I don't have the same problems, please confirm.
I also noticed that your pdf export doesn't have all the problems in the screenshot.

I downloaded the font from http://www.fonts2u.com/b-roya.font

Ubuntu 14.10 64-bit
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Comment 4 Yousuf Philips (jay) (retired) 2015-02-02 18:01:26 UTC
Likely a duplicate of bug 35320.
Comment 5 Eman Amini 2015-02-03 06:42:09 UTC
(In reply to Beluga from comment #3)
> Created attachment 113049 [details]
> PDF export from 4.4.0.3
> 
> It seems I don't have the same problems, please confirm.
> I also noticed that your pdf export doesn't have all the problems in the
> screenshot.
> 
> I downloaded the font from http://www.fonts2u.com/b-roya.font
> 
> Ubuntu 14.10 64-bit
> Version: 4.4.0.3
> Build ID: 40m0(Build:3)

Actually the problem is also presence of the bug your file.
In line 2: 
به، حال، گزارش، هیچ‌گاه
In line 4:
به
the five words above have the problem.
And in line 5:
دهد، این، مورد
In the three words above I think kashida is missed. characters of these word has not joined together properly.
Comment 6 Yousuf Philips (jay) (retired) 2015-02-03 13:36:02 UTC
Closing this as a duplicate of bug 35320 which deals with the same kashida justification problem of this bug.

*** This bug has been marked as a duplicate of bug 35320 ***