Bug 88978 - CRASH - Segfault on bitmap smooth and sharpen functions on LibO 4.4
Summary: CRASH - Segfault on bitmap smooth and sharpen functions on LibO 4.4
Status: RESOLVED DUPLICATE of bug 87639
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-01-31 13:49 UTC by Callegar
Modified: 2015-12-05 14:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2015-01-31 13:49:12 UTC
To reproduce

1) Open a new drawing
2) Draw a rectangle
3) Convert to a bitmap
4) Try to apply the 'smooth' operation on it

See the crash that on my system happens systematically.

Up to 4.3 LibO was fine on these operations.
Comment 1 Buovjaga 2015-01-31 14:39:34 UTC
(In reply to sergio.callegari from comment #0)
> 4) Try to apply the 'smooth' operation on it

How can I do this?
Comment 2 Alex Thurgood 2015-01-31 15:44:04 UTC
I can reproduce this with 440 production release on Linux Mint 17.1
Comment 3 Alex Thurgood 2015-01-31 15:48:58 UTC
No crash in Version: 4.2.7.2
Build ID: 420m0(Build:2)
Comment 4 Alex Thurgood 2015-01-31 15:53:21 UTC
How to reproduce :

1) Start LibreOffice Draw
2) Draw a rectangle with the pre-configured shape toolbar.
3) With the rectangle selected, right mouse button click and choose Convert to bitmap
3) Now click on the Wand in the upper left hand corner of the draw window, and choose Smooth from the list of filters to apply to the bitmap.
4) Crash

What should happen :
4) The Smooth filter dialog settings should be displayed, allowing the user to tailor the filter, and then the filter should be applied correctly.
Comment 5 Alex Thurgood 2015-01-31 20:50:04 UTC
Output in gdb :

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff24ba25a in BitmapReadAccess::SetPixelFor_24BIT_TC_BGR(unsigned char*, long, BitmapColor const&, ColorMask const&) ()
   from /home/alex/Downloads/LibreOffice_4.4.0.3_Linux_x86-64_deb/DEBS/install/opt/libreoffice4.4/program/libvcllo.so
Comment 6 Alex Thurgood 2015-01-31 22:11:46 UTC
No crash with debug build from master

Version: 4.5.0.0.alpha0+
Build ID: 8fd9c25ac66dd238d4c68be3974241a18cb21705
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-27_22:43:15
Locale: fr_FR
Comment 7 Julien Nabet 2015-02-01 17:27:28 UTC

*** This bug has been marked as a duplicate of bug 87639 ***
Comment 8 Julien Nabet 2015-12-05 14:50:02 UTC
cleanup keywords