Bug Hunting Session
Bug 88990 - Adjusting or removal of background fill for text "highlighting" could be improved
Summary: Adjusting or removal of background fill for text "highlighting" could be impr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-31 19:08 UTC by Bryant
Modified: 2017-08-23 09:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bryant 2015-01-31 19:08:38 UTC
In Word 2010 un-highlighting text entails just re-highlighting it. In LO it's not obvious how to un-highlight. Looks like the expected method is to select "No fill" with the highlighting tool and then highlight the text with that. This is very inconvenient when you accidentally over-highlight by a few character as it's a lot of UI activity. Additionally having similar tool functionality to Word is likely an effective tool for converting users.
Comment 1 V Stuart Foote 2015-01-31 19:40:04 UTC
Yup, seems reasonable. But applying the "no fill" to remove highlighting is not really the issue. 

Rather, the issue is selecting the text with background highlighting you need to correct.  We can double-click select an entire word, but we miss any over-shoot of the highlighting.

What might be more functional would be to provide for text selection based on highlighted state, so rather than double-click select, provide a <Shift>-double click to select highlighted block. Don;t know if there is a clear HIG suggestion, but something along that line.

Mode test would be highlighted vs. paragraph default.

While at it, might also look at the same for changing font color, which we now select and set back to "Automatic" to clear its color.

Over to ux-advise for comment, suggestions.
Comment 2 Bryant 2015-01-31 21:06:00 UTC
So it sounds like you suggest there are actually 3 things here to work on:

 1) Using re-highlighting as a way of "undoing" previous highlighting
 2) Being able to easily select accidently-highlighted text for cleanup

As for 1, it sounds like we're in agreement but "undoing" should entail restoring the previous highlighting choice. So why not utilize the undo stack and instead of clearing any highlighting actually just undo the highlighting and restoring the previous highlighted color? This may be difficult as the text selection would be part of the undo stack save, but this is effectively what we want to achieve.

And as for 2, adding the shift-double-click for range selection of content already styled the same was as the current tool selection would definitely be useful. I also see it being helpful to apply it to any similar tools, like the font color, as you propose.

So I actually see both of these as independent issues, though both help a user fix the accidental-over-highlighting problem.

And just as a side-note, Word 2010 does not remember previous highlighting states, it just clears to no-highlighting when re-highlighting.
Comment 3 V Stuart Foote 2015-01-31 22:55:40 UTC
(In reply to Bryant from comment #2)
> As for 1, it sounds like we're in agreement but "undoing" should entail
> restoring the previous highlighting choice. 

Highlighting is normally applied as direct formatting against the style (usually "default") so there would be nothing "previous" to revert to, just back to the applied paragraph style.

> So why not utilize the undo
> stack and instead of clearing any highlighting actually just undo the
> highlighting and restoring the previous highlighted color? This may be
> difficult as the text selection would be part of the undo stack save, but
> this is effectively what we want to achieve.

That is an implementation issue for a devs, but suspect the serial nature of the undo stack is going to be too costly to use to try to identify the highlight action (or other direct formatting) to revert. Think of trying to go back through a couple of dozen paragraphs of new text including direct formatting actions in order to identify a single highlighting action to be reverted.

Believe it is going to be more efficient if done as a current text selection--aided by a smart selection/detection of some type.
Comment 4 Cor Nouws 2015-02-03 11:24:39 UTC
Hi Bryant,

(In reply to Bryant from comment #0)
> .. This is very inconvenient when you accidentally over-highlight by a
> few character as it's a lot of UI activity. Additionally having similar tool
> functionality to Word is likely an effective tool for converting users.

Select and hitting Ctrl+M (Format>Default formatting) absolutely is the most convenient way here. For me this needs no improvement. It's maybe easier then exactly having to select the same text and hitting the button again?
Comment 5 V Stuart Foote 2015-02-03 12:38:24 UTC
(In reply to Cor Nouws from comment #4)
Hi Cor (welcome back to BZ...),
> > .. This is very inconvenient when you accidentally over-highlight by a
> > few character as it's a lot of UI activity. Additionally having similar tool
> > functionality to Word is likely an effective tool for converting users.
> 
> Select and hitting Ctrl+M (Format>Default formatting) absolutely is the most
> convenient way here. For me this needs no improvement. It's maybe easier
> then exactly having to select the same text and hitting the button again?

But the problem is doing the selection of the "highlighted" text to correct. Double click works at word boundaries, so currently limited to a mouse swipe or cursor (L,R) to make a selection. 

Additionally we need to be able to select by "state" to detect highlighting (or other direct formatting)--i.e. does the text cursor point to text with direct formatting attributes and so differ from style of current paragraph--select that text for an action.

That should be granular enough--to use a <Ctrl>+M--or just reapply a new color fill from the picker.
Comment 6 Robinson Tryon (qubit) 2016-08-25 04:45:01 UTC Comment hidden (obsolete)
Comment 7 Heiko Tietze 2017-08-23 09:43:09 UTC
Highlight behavior: Word toggles the text background. But this feature is inconsistent and works solely for the highlighting and not the font color or other properties. LibO has the 'no fill' quick setting (like Word) as well as ctrl+M to clear any direct formatting, and Undo to revert the last operation. That works for most of us, I guess.

Selection per double-click nicely finds the word without this (terrible) 'overshooting'. But using the keyboard shift+ctrl+right you select also all white-space characters until the next word. So both variants are available (while Word has only one and does always overshoot).

Select not by cursor/keyboard but depending on style or properties sounds to me as out of scope. If you want to change the appearance of text at many places, unclear positions etc. you should use the character style.

So putting all together it WFM perfectly and we shouldn't copycat all Microsoft ideas.