Download it now!
Bug 89120 - Writer is very slow at saving this file with svg images
Summary: Writer is very slow at saving this file with svg images
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, perf, regression
Depends on:
Blocks:
 
Reported: 2015-02-04 13:36 UTC by Frederic Parrenin
Modified: 2018-09-20 08:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.odt file to reproduce the problem (5.08 MB, application/vnd.oasis.opendocument.text)
2015-02-04 13:36 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2015-02-04 13:36:25 UTC
Created attachment 113124 [details]
.odt file to reproduce the problem

Steps to reproduce:
- open the attached .odt file
=> it opens in ~1s
- insert a character somewhere and save the file
=> it takes ~15 s
The slowness of writer when saving is annoying when you work on the file.
Moreover, I don't understand why the saving is an order of magnitude slower than the opening, some optimisation might be possible here.
The slowness might be related to the fact that it contains svg images.
Comment 1 Buovjaga 2015-02-07 20:04:45 UTC
Reproduced, but not with 3.5.0.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 99c00b090533da9818444be2831b8da0e713e5f9
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-04_06:38:53
Locale: fi_FI

Ubuntu 14.10 64-bit
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 Rostislav 'R.Yu.' Okulov 2015-02-07 21:12:28 UTC
git bisect log
git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect bad 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [51b63dca7427db64929ae1885d7cf1cc7eb0ba28] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good 51b63dca7427db64929ae1885d7cf1cc7eb0ba28
# bad: [d65a58c31c8da044ef66ae4517fa2fe74cec0019] source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
git bisect bad d65a58c31c8da044ef66ae4517fa2fe74cec0019
# good: [79e02001f27d33b3b478324ab6fba5683413b4d9] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect good 79e02001f27d33b3b478324ab6fba5683413b4d9
# bad: [1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e] source-hash-11e776023c89b3de690b37ffaed18ec996b9c207
git bisect bad 1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e
# bad: [5809284e8a6f97fe3b5beb037b6b80eeb9fe1058] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
git bisect bad 5809284e8a6f97fe3b5beb037b6b80eeb9fe1058
# bad: [99f63b2b53c0e22baac045d54f502508d7150fef] source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb
git bisect bad 99f63b2b53c0e22baac045d54f502508d7150fef
# good: [1f14665c5624bc7a502738aa8f4f2bd70a211e72] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect good 1f14665c5624bc7a502738aa8f4f2bd70a211e72
# first bad commit: [99f63b2b53c0e22baac045d54f502508d7150fef] source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb

99f63b2b53c0e22baac045d54f502508d7150fef is the first bad commit
commit 99f63b2b53c0e22baac045d54f502508d7150fef
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 05:45:37 2012 +0000

    source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb
    
    commit d38a2e3ea04d354492df18aa16d2304babe87dfb
    Author:     Andras Timar <atimar@suse.com>
    AuthorDate: Thu Nov 22 07:01:11 2012 +0100
    Commit:     Gerrit Code Review <gerrit@vm2.documentfoundation.org>
    CommitDate: Thu Nov 22 06:00:42 2012 +0000
    
        Updated core
        Project: help  53421e107f2e8c933e463e03a6bb7a0178b3ff85
        move Presenter Console help to main help

:100644 100644 03a040999f63a580a1509f0d908fa9a9f149fad1 c3c6030ca2524901562ab3929e935673afc71830 M      autogen.log
:100644 100644 760e368a7df5a07687a83c81a51e73bb80c62ceb 2c2bed043e9f7db2c6b83b8d335720cab50ca674 M      ccache.log
:100644 100644 88657431c9c9c0aa14b8c93c720e3c6b5222d64a c1da9e4ff9610086cab73a134a1120fddb0ee4a6 M      commitmsg
:100644 100644 793e45124d193a35b8925402bda4e8f14e9dba8c cda5ea59bdebfe2bfe39e2dfd18922c94824e38f M      dev-install.log
:100644 100644 54ed0708af49cfca9bbbe4c60484adbb1f3628f1 0a121b8ec2c59d8c7b1a2c51f2c643b288216d9d M      make.log
:040000 040000 8e2ebefc6e5ba8a91bf16e7cdef72824536b4fb0 d06b2228c45cf5234fd35d57f9e696bd6706b396 M      opt
Comment 3 Frederic Parrenin 2015-06-18 02:52:08 UTC
This bug is still present on 4.4.4.2 on ubuntu 14.04.
Comment 4 Frederic Parrenin 2015-06-18 05:37:41 UTC
This bug is still present in 5.0.0.0beta3 on ubuntu 14.04.
Comment 5 Frederic Parrenin 2015-08-07 22:28:07 UTC
The situation has improved in 5.0.0.5 since it takes only ~8 s to save the file.
Comment 6 Robinson Tryon (qubit) 2015-12-10 09:46:19 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2017-09-14 09:33:17 UTC
Same range of commits as in bug 101083. Adding to see also...
Comment 9 QA Administrators 2018-09-15 03:10:01 UTC Comment hidden (obsolete)
Comment 10 Frederic Parrenin 2018-09-20 08:25:07 UTC
It seems the situation has improved, since it now takes only 1 or 2 s the save the file. I propose to mark this bug as fixed.
Comment 11 Buovjaga 2018-09-20 08:36:28 UTC
Hey, that is excellent news.