Download it now!
Bug 89137 - More than 2 remotely linked images don't work in Writer
Summary: More than 2 remotely linked images don't work in Writer
Status: RESOLVED DUPLICATE of bug 88935
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-05 14:19 UTC by Lukas Jelinek
Modified: 2015-02-11 13:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Error messages instead of images (175.44 KB, image/png)
2015-02-05 14:19 UTC, Lukas Jelinek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jelinek 2015-02-05 14:19:07 UTC
Created attachment 113146 [details]
Error messages instead of images

If I insert more than two remotely linked images into a Writer document it leads to some form of "corruption" of two of these images (error messages are displayed instead of the images).

Steps to reproduce:
1) Start Writer (a new document is created).
2) Use from the menu bar: Insert -> Image... (a dialog opens).
3) Check the "Link" checkbox, write an existing image URL into the file name text field and press "Open".
4) Press the "Keep link" in the confirmation dialog.
5) Click to another position in the document.
6) Repeat the steps 2 - 5 twice again.

Expected result:
There are three images in the document.

Current result:
There is only one valid image. Instead of the two other images there are only two frames where URLs and "Read-Error" texts are displayed alternately. In some occasions, all images are correctly displayed first but after moving the view it changes to the state described before.

The same applies for the situation where these images are inserted directly into the document (not linked) and they are subsequently changed to the linked versions (by specifying their URLs in image context dialogs).
Comment 1 Buovjaga 2015-02-07 19:33:53 UTC
Could not reproduce.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Ubuntu 14.10 64-bit
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US
Comment 2 Robinson Tryon (qubit) 2015-02-08 09:15:46 UTC
(In reply to Beluga from comment #1)
> Could not reproduce.
> 
> Win 7 Pro 64-bit, LibO Version: 4.4.0.3

Hi, Lukas.

Looks like we're having trouble reproducing your problem. What version of Windows are you using with LibreOffice? Do you see the same problem on a different computer?

Status -> NEEDINFO

(After you provide feedback, please change status back to UNCONFIRMED. thanks!)
Comment 3 Lukas Jelinek 2015-02-08 16:37:23 UTC
Hi,
the problem occurs on all of my computers with various systems:

- Windows Vista Home Premium 32bit
- Windows 7 Professional 64bit
- Kubuntu 14.10 64bit

I tested first three images from this webpage: http://www.openoffice.cz/recenze/zen-novinek-v-libreoffice-4-4-prvni-cast

But it worked the same way also for other images both from this page and from any others I tested.
Comment 4 blargh 2015-02-11 08:20:32 UTC
Appears to be the same that's reported here: https://bugs.documentfoundation.org//show_bug.cgi?id=88845
Comment 5 blargh 2015-02-11 08:22:23 UTC
(In reply to blargh from comment #4)
> Appears to be the same that's reported here:
> https://bugs.documentfoundation.org//show_bug.cgi?id=88845

Damn, that was the wrong link.

Here's the right link: https://bugs.documentfoundation.org//show_bug.cgi?id=88935
Comment 6 V Stuart Foote 2015-02-11 13:09:34 UTC
Pretty clearly duplicate of bug 88935 which is on 4.4 MAB

*** This bug has been marked as a duplicate of bug 88935 ***
Comment 7 V Stuart Foote 2015-02-11 13:30:06 UTC
@Lukas, *,

Confirming, but setting as duplicate of bug 88935. Have attached a test document of this linked image use case there.