Download it now!
Bug 89233 - external data reference gets broken when saving in MS Excel 2003 (xls) format
Summary: external data reference gets broken when saving in MS Excel 2003 (xls) format
Status: RESOLVED DUPLICATE of bug 48463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-08 17:02 UTC by PeterP
Modified: 2015-02-08 21:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet examples (20.38 KB, application/zip)
2015-02-08 17:02 UTC, PeterP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PeterP 2015-02-08 17:02:01 UTC
Created attachment 113235 [details]
spreadsheet examples

An external data reference in an ods sheet:

='file:///home/peter/tmp/dir_a/src.ods'#$Tabelle1.A1

is changed to:

='file:///home/peter/tmp/dir_a/home/peter/tmp/dir_a/src.ods'#$Tabelle1.A1
                               ^^^^^^^^^^^^^^^^^^^^^
when the file is saved in MS Excel 2003 (xls) format and then re-opened again. 
Each subsequent save/open is adding another extra string like this:

='file:///home/peter/tmp/dir_a/home/peter/tmp/dir_a/home/peter/tmp/dir_a/src.ods'#$Tabelle1.A1
Comment 1 m.a.riosv 2015-02-08 21:46:11 UTC
Hi @PeterP, thanks for reporting.

I think this is a duplicate of:
https://bugs.documentfoundation.org/show_bug.cgi?id=48463

As workaround you can put the path in a cell and use the INDIRECT() function (or put directly as text in the function) to compose the address properly, in this way nothing is changed when saving the file.

e.g.

B10: ="'file:///Users/me/Users/me/file.ods'#Sheet1."
c10: =INDIRECT(B10&cell("address";A1))

*** This bug has been marked as a duplicate of bug 48463 ***