Download it now!
Bug 89249 - LibreOffice crashes when using fields in a template made in an older version of LibreOffice...
Summary: LibreOffice crashes when using fields in a template made in an older version ...
Status: RESOLVED DUPLICATE of bug 82942
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Marqeaux
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-02-09 10:36 UTC by Marqeaux
Modified: 2015-12-17 08:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example_reproduction_bug_89249. (39.61 KB, application/vnd.oasis.opendocument.text)
2015-02-11 13:41 UTC, Marqeaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marqeaux 2015-02-09 10:36:34 UTC
When opening a self made template with custom fields made in an earlier version of LibreOffice Writer, the program crashes when clicking "next" for the following custom field. This doesn't happen when the template is made in LibreOffice 4.4.0.3 itself. But when opening a template made in an earlier version of LibreOffice, it crashes immediately when entering the next field in the document.

I couldn't reproduce the same behaviour in LibreOffice 4.2.8, which we use at the office. In this version it works fine.
Comment 1 bfoman (inactive) 2015-02-10 22:25:56 UTC
Could you please attach a problematic template to allow others to confirm the issue?
Comment 2 raal 2015-02-11 09:01:34 UTC
Hello Marqeaux,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 3 Marqeaux 2015-02-11 13:39:11 UTC
Hi there,

Just like you asked I attached a template I use on a regular bases at work. When I open this self made template in LibreOffice 4.2.8, it just works fine. When opening it in LibreOffice 4.4.0.3 (at this moment in use at our office), it crashes when changing the value of the field. It happens over and over again.

I hope you can reproduce this behaviour and fix this. :-)

Kind regards,
Marqeaux.
Comment 4 Marqeaux 2015-02-11 13:41:15 UTC
Created attachment 113310 [details]
Example_reproduction_bug_89249.
Comment 5 raal 2015-02-11 13:56:23 UTC
I can open file without crash with Version: 4.5.0.0.alpha0+
Build ID: 40432ac6caa478474d73786f95b808c14e106ff2
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-03_01:24:42

I can not reproduce the crash with Version: 4.4.0.3
ID build: de093506bcdc5fafd9023ee680b8c60e3e0645d7, win7
Comment 6 Marqeaux 2015-02-11 16:45:19 UTC
(In reply to raal from comment #5)
> I can open file without crash with Version: 4.5.0.0.alpha0+
> Build ID: 40432ac6caa478474d73786f95b808c14e106ff2
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-02-03_01:24:42
> 
> I can not reproduce the crash with Version: 4.4.0.3
> ID build: de093506bcdc5fafd9023ee680b8c60e3e0645d7, win7

It's not the opening of the file that causes the crash, but the form fields. When you open the template, and when the text field pops-ups, you have to fill in something. When you click "next" (or ALT+V), it crashes. Sometimes immediately, sometimes after clicking a couple of time on "next".

I tried it this afternoon with this particular example I sended, and it crashed again. When I did exactly the same in LibreOffice 4.2.8., everything worked fine...

Again: opening this file isn't the problem. It's the use of form fields in this document, which are made in an earlier version of LibreOffice, that is causing the trouble. When I make a template in LibreOffice 4.4.0.3, and I try to do as described above, everything works okay...
Comment 7 Buovjaga 2015-02-11 18:01:10 UTC
Confirmed crash on "Next" in 4.4, but not in 4.5 (or 3.5).
Adding bibisect request.

Bibisecters: please also bibisect from 4.4 to 4.5 to find out, where it started working again.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: e98b6027458dd9410e27c5f273f4db5cc1443b01
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-02-05_02:48:19
Locale: en_US

Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 8 Caolán McNamara 2015-02-12 13:52:35 UTC

*** This bug has been marked as a duplicate of bug 82942 ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 08:46:36 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]