Bug 89272 - EDITING: Navigating by bookmark in a document without bookmarks causes app to CRASH
Summary: EDITING: Navigating by bookmark in a document without bookmarks causes app to...
Status: RESOLVED DUPLICATE of bug 85004
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-09 21:17 UTC by serdar
Modified: 2019-10-25 08:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description serdar 2015-02-09 21:17:25 UTC
When editing a document that has no bookmarks -- for instance, a completely empty document -- attempting to navigate by bookmark causes the entire application to crash.

The crash seems to happen most often if attempting to navigate by bookmark is the first action taken after editing. (If I create a blank document, type, and THEN navigate by bookmark, nothing untoward happens; the cursor simply doesn't change position as expected.)
Comment 1 Buovjaga 2015-02-10 10:59:54 UTC
There was a recent navigator crash fix committed yesterday (bug 85004).
Can you try with a pre-release version of 4.4.x and see, if the crash still occurs?
You can get one here: http://dev-builds.libreoffice.org/daily/libreoffice-4-4/Win-x86@42/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED DUPLICATE of bug 85004, if the problem went away.
Comment 2 serdar 2015-02-10 13:54:18 UTC
Will do, I'll see what happens there.
Comment 3 serdar 2015-02-11 22:16:01 UTC
The bug appears to be fixed in the newer builds, so I suspect this was a side effect of 85004.

*** This bug has been marked as a duplicate of bug 85004 ***
Comment 4 Kerry Reed 2019-10-25 08:28:06 UTC Comment hidden (spam)