Download it now!
Bug 89312 - 'csv' Files are Opened as Text Documents if Writer is the Active Window
Summary: 'csv' Files are Opened as Text Documents if Writer is the Active Window
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-11 17:02 UTC by Harald Koester
Modified: 2015-02-26 14:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-02-11 17:02:06 UTC
A csv file is generally used to store structured data which can be represented in a spreadsheet. Hence to my opinion csv files should be opened with Calc by default. Only if a user explicitly selects “Text document” a csv file should be opened with Writer. This is currently not always the case or possible.
Steps in order to reproduce the bug.

[A] First case:
(1) Start LO and create new text document.
(2) Open a file with the extension 'csv' from the menu: File > Open... The open file dialogue of Windows is displayed. In the status line the filter “All files (*.*)” is selected.
(3) Select a csv file and click “Open”. The csv file is loaded as text document. Expected: csv file should be opened as spreadsheet by default even it is opened from a text document.

[B] Second case:
(1) Start LO and create new text document.
(2) Open a file with the extension 'csv' from the menu: File > Open... The open file dialogue of Windows is displayed. In the status line the filter “All files (*.*)” is selected.
(3) Select “Spreadsheets (…;*.csv)” as filter.
(4) Select a csv file and click “Open”... The csv file is loaded as text document. Expected: csv file should be opened as spreadsheet. In this case even if the user selects the option spreadsheet the file is opened as text document.

[C] Third case: You like to open a csv file explicitly as text document.
(1) Start LO.
(2) File > Open…
(3) Select filter “Text documents (*.oth; ...)”. csv files are not displayed. Hence csv files can't be opened now as text documents. Expected: Also csv files should be displayed.

[D] 4. case:
(1) Start LO and Create new text document.
(2) Open a file with the extension 'csv' from the menu: File > Open... The open file dialogue of Windows is displayed. In the status line the filter “All files (*.*)” is selected.
(3) Select “Text CSV (*.csv)” as filter.
(4) Select a csv file and click “Open”... The csv file dialogue is opened and the file is opened as spreadsheet when you click OK. Here the behaviour is OK.

Additional hint: In some older bug reports files with extension 'tsv' (tab-separated values, see: http://en.wikipedia.org/wiki/Tab-separated_values) are mentioned. It seemed to me that there is a special treatment in LibreOffice similar to csv files. If this is the case, files with these extensions should be treated completely equal to csv files. This is currently not the case in the file filters of the file open dialogue, files with the extension tsv are not mentioned there.
Comment 1 raal 2015-02-12 10:25:55 UTC
Setting as enhancement.
I disagree, leaving unconfirmed.
Comment 2 Jean-Baptiste Faure 2015-02-14 21:26:45 UTC
I disagree too.

Best regards. JBF
Comment 3 Robinson Tryon (qubit) 2015-02-19 00:07:17 UTC
(In reply to Harald Koester from comment #0)
> A csv file is generally used to store structured data which can be
> ...
> Additional hint: In some older bug reports files with extension 'tsv'
> (tab-separated values, see:

Sounds like we've got a bunch of different things all combined together into one bug report, so I'm going to take the easy way out and address just one item.

I like the '.tsv' extension, especially because parsing TAB chars is much easier than dealing with embedded commas. I think it does make sense for us to have the same behavior for CSV and TSV files.

That being said, please split-up this report into a couple of bugs. One might be "consistent behavior of handling CSV files no matter which application is open" ?
Comment 4 Harald Koester 2015-02-26 14:38:41 UTC
Bug splitted into 3 new bug reports:

(1) Bug 89683: 'csv' Files are Opened as Text Documents if Writer is the Active Window 
(2) Bug 89684: 'csv' Files Can't be Opened as Text Documents
(3) Bug 89685:  Missing Support of Files with the Extension “tsv”

Hence these 3 reports replace this bug (89312) status set to RESOLVED INVALID.