Bug Hunting Session
Bug 89316 - Logo image on page1 header corrupted when saved as docx
Summary: Logo image on page1 header corrupted when saved as docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-11 19:23 UTC by Zeki Bildirici
Modified: 2016-09-09 12:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Original ODT file (138.57 KB, application/vnd.oasis.opendocument.text)
2015-02-11 19:23 UTC, Zeki Bildirici
Details
File saved as docx on LibO 4.4 (72.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-02-11 19:23 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2015-02-11 19:23:19 UTC
Created attachment 113323 [details]
Original ODT file

Hi,

When saving the attached document as docx, the europass logo on the header is corrupted

Steps:
1- Download attached odt file and save as docx
2- Close the document and reopen it with LibreOffice 4.4

Opening the file with Microsoft Word 2013 is fine, the logo is fine.

Version: 4.4.0.3
Build NO: de093506bcdc5fafd9023ee680b8c60e3e0645d7

Re bug: https://bugs.documentfoundation.org/show_bug.cgi?id=89297 (item 3 on comment 3)

Best regards,
Zeki
Comment 1 Zeki Bildirici 2015-02-11 19:23:45 UTC
Created attachment 113324 [details]
File saved as docx on LibO 4.4
Comment 2 raal 2015-02-13 15:42:06 UTC
I can not confirm with Version: 4.5.0.0.alpha0+
Build ID: 62969accf9c01b71b738424d4d643db8bfaed182
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-08_23:22:3
Comment 3 Robinson Tryon (qubit) 2015-02-19 00:12:32 UTC
TESTING with 4.4.0.3 + Ubuntu 14.04:

- Open attachment 113323 [details] with Writer, and save as DOCX
> 2- Close the document and reopen it with LibreOffice 4.4
> 

Yep

> 
> When saving the attached document as docx, the europass logo on the header
> is corrupted

CONFIRMED -- there appears to be a blank textbox or something similar over the logo.

Status -> NEW
Comment 4 Xisco Faulí 2015-08-20 15:59:01 UTC
I can no longer reproduce this issue with

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)

Thus, I close it as RESOLVED WORKSFORME
Comment 5 Cor Nouws 2015-10-10 15:08:47 UTC
Bug is still present..
Comment 6 Cor Nouws 2015-10-10 15:12:48 UTC
1. Open 89316_CVTemplate.odt in 5.0.3.1
2. Save as Docx
3. Close
4. Open in LibreOffice or MsWord 2010
 > Logo in header page 2 is lost

The orginal document has styles:
 page 1: Default
 page 2: SmallerHeader

The docx document has styles:
 page 1: Default
 page 2: Default
Comment 7 Cor Nouws 2015-10-10 15:13:14 UTC
@zeki:  do you know if this ever worked correct?
thanks! Cor
Comment 8 Cor Nouws 2015-10-10 16:04:06 UTC
already a problem in 3.3.0
Comment 9 Justin L 2016-09-09 11:13:26 UTC
Setting to works for me.  Tested Ubuntu 16.04 and LO5.1 (works) and 5.3dev(works).  (also see comment #4)

comment #6: Cor, this bug is specifically dealing with a corrupt picture in the header on page1.  Page2 style being lost (and thus no header) is documented in related bug 89297
Comment 10 Cor Nouws 2016-09-09 12:22:28 UTC
(In reply to Justin L from comment #9)

> comment #6: Cor, this bug is specifically dealing with a corrupt picture in
> the header on page1.  Page2 style being lost (and thus no header) is
> documented in related bug 89297

OK, sorry - thanks for clarifying Justin.