Bug Hunting Session
Bug 89409 - binary Word DOC import: ruby text height is 0
Summary: binary Word DOC import: ruby text height is 0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Mark Hung
URL:
Whiteboard: target:6.0.0
Keywords: filter:doc
Depends on:
Blocks: CJK DOC Text-Grid
  Show dependency treegraph
 
Reported: 2015-02-16 08:42 UTC by Andras Timar
Modified: 2017-10-01 07:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (DOC) (87.00 KB, application/msword)
2015-02-16 08:42 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-02-16 08:42:41 UTC
Created attachment 113425 [details]
bugdoc (DOC)

The attached file is a binary Word document created with Word2010. It contains Chinese characters with ruby text above the characters. Line grid is set for the page layout. In Writer first we see the ruby text, but after scrolling the document with the mouse wheel, they disappear. (For the grid line height mismatch I reported a different bug, that is bug 88752.)

The problem is that ruby height is set to 0 here:
http://opengrok.libreoffice.org/xref/core/sw/source/filter/ww8/ww8par6.cxx#305
Comment 1 Robinson Tryon (qubit) 2015-02-17 23:48:00 UTC
TESTING with 4.4.0.3 + Ubuntu 14.04

REPRO steps:
- Open attachment 113425 [details] in Writer
- In Writer first we see the ruby text, but after scrolling the document with the mouse wheel, they disappear.

CONFIRMED: Text disappears after scrolling (with edge of touchpad)

Status -> NEW
Comment 2 QA Administrators 2016-02-21 08:35:05 UTC Comment hidden (obsolete, spam)
Comment 3 Xisco Faulí 2017-08-01 16:06:23 UTC
Patch submitted to gerrit by Mark Hung: https://gerrit.libreoffice.org/#/c/40632/
Comment 4 Commit Notification 2017-08-11 15:52:27 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3579e74dec0db203566df1e356af9b06374ef9c

tdf#89409 Render ruby inside the grid in standard mode.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2017-09-11 08:13:10 UTC
Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED