Download it now!
Bug 89433 - LibreOffice Calc Goal Seek Fail
Summary: LibreOffice Calc Goal Seek Fail
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GoalSeek
  Show dependency treegraph
 
Reported: 2015-02-17 14:32 UTC by aesche
Modified: 2017-07-15 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Formula showing Goal Seek cannot solve for the solution (9.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-02-17 14:32 UTC, aesche
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aesche 2015-02-17 14:32:09 UTC
Created attachment 113462 [details]
Formula showing Goal Seek cannot solve for the solution

Hi,
Mathematician, not programmer here, but LibreOffice Calc didn't seem to iterate through 20 integers on this latest problem.  I was trying to solve for Pythagorean triples with the same area -- I used the INT command to plug in for the nearest integer automatically, used the pythagorean theorem for the length of the hypotenuse, subtracted the calculated hypotenuse length from the INT output of that length, and set Goal Seek to set that cell to zero.  Goal Seek didn't give any valuable solutions, sets the target variable to zero and doesn't find the solution.  The solution is not that difficult - any number near 12, 20, 21 or 35 should solve the equation.  File attached.
Comment 1 Jean-Baptiste Faure 2015-05-25 16:41:02 UTC
(In reply to aesche from comment #0)
> The solution is not that difficult - any number near 12, 20, 21 or 35 should 
> solve the equation. 

So, if I understand right, that means that the problem is not linear (use of INT() function and exponentiation) and has multiple solutions.

Please, could you explain step by step what to do to reproduce the problem with your file?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested information.

Best regards. JBF
Comment 2 QA Administrators 2015-12-27 20:31:29 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2016-01-03 21:05:31 UTC
Closing as INVALID.
Please feel free to reopen and set as UNCONFIRMED if you are willing providing requested information.

Best regards. JBF