Bug Hunting Session
Bug 89445 - FORMATTING: Styles and Formatting > Load Styles works correctly from document and not template
Summary: FORMATTING: Styles and Formatting > Load Styles works correctly from document...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 50699 Sidebar-Styles Styles-Load
  Show dependency treegraph
 
Reported: 2015-02-17 22:04 UTC by Jon Grossart
Modified: 2017-06-07 00:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Copy of default LibO 4.4 Template (8.33 KB, application/vnd.oasis.opendocument.text-template)
2015-02-17 22:07 UTC, Jon Grossart
Details
Starting Text File with formatting to see correct results (9.80 KB, application/vnd.oasis.opendocument.text)
2015-02-17 22:07 UTC, Jon Grossart
Details
Altered Formatted Text to use to test loading styles (10.12 KB, application/vnd.oasis.opendocument.text)
2015-02-17 22:08 UTC, Jon Grossart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Grossart 2015-02-17 22:04:55 UTC
If you go to load styles from a document, the styles all get updates correctly (at least font, font effects, and border settings).

However, if you do the same thing from a template file, it only updates the font settings, and not the others.

1. load blank document
2. enter some formatted text (I used headings, changing font type, color, and adding border lines).
3. save document
4. go to "Styles and Formatting" > "Load Styles" and pick either from a templete or From File > and then select a template file. Make sure "Text" and "Overwrite" are selected.
5. document will only change font family/size
6. go back and load styles from an actual document, with "Text" and "Overwrite" and the document will be correctly updated.

Expected Results:
I would think that all the styles would be correctly updated, regardless of if it's from a template or a document.
Comment 1 Jon Grossart 2015-02-17 22:06:12 UTC
I should note that I test from 3.6.7.2 all the way up to 4.4.0.3. The problem from loading from template was in all of them, so it's not new.

I'm not sure how far back the loading from document works as I found that correctly working path later. "From File" does seem to work correctly in 4.4.0.3.
Comment 2 Jon Grossart 2015-02-17 22:07:00 UTC
Created attachment 113474 [details]
Copy of default LibO 4.4 Template
Comment 3 Jon Grossart 2015-02-17 22:07:28 UTC
Created attachment 113475 [details]
Starting Text File with formatting to see correct results
Comment 4 Jon Grossart 2015-02-17 22:08:07 UTC
Created attachment 113476 [details]
Altered Formatted Text to use to test loading styles
Comment 5 Buovjaga 2015-02-24 09:24:15 UTC
Reproduced by opening Default Styles-Edited.odt and loading styles from LibO 4.4.ott (with Text + Overwrite enabled).

Lowered severity per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Ubuntu 14.10 
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US
Comment 6 Jon Grossart 2015-02-26 05:17:22 UTC
I should also clarify the bug slightly:

1) loading styles works correctly from a document or a template file if you use the "From File" option.
2) loading styles does not work correctly/fully if you just chose a template from the selector (and you can even be using the same template from point #1).
Comment 7 tommy27 2016-04-16 07:28:16 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-05-22 13:26:06 UTC Comment hidden (obsolete)
Comment 9 Jon Grossart 2017-06-06 18:22:13 UTC
At some point this bug was fixed.

It is working correctly in 5.3.3 64-bit on W10 64-bit.

I am marking it as resolved -- works for me.