Bug 89644 - FORMATTING: Bibliography structure character style problem
Summary: FORMATTING: Bibliography structure character style problem
Status: RESOLVED DUPLICATE of bug 77919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-25 10:16 UTC by jzmigrodzki
Modified: 2015-04-17 18:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
print screen w strange element caption (188.23 KB, image/jpeg)
2015-02-25 10:16 UTC, jzmigrodzki
Details
ODT file with problematic bibliography (29.97 KB, application/vnd.oasis.opendocument.text)
2015-03-02 20:38 UTC, jzmigrodzki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jzmigrodzki 2015-02-25 10:16:12 UTC
Created attachment 113667 [details]
print screen w strange element caption

There is a problem at applying the character style for elements of the structure of the bibliography list. When character style is apply, document saved,reopen and than bibliography is rebuild again character styles disappear. The captions of bibliography structure look strange (see atached file).
Comment 1 Buovjaga 2015-02-28 14:12:20 UTC
Can you attach a small example document so we can test more quickly?
Thanks.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 jzmigrodzki 2015-03-02 20:38:13 UTC
Created attachment 113839 [details]
ODT file with problematic bibliography

I added ODT file with bibliografy in which this problem ocure.
Comment 3 Buovjaga 2015-03-03 15:24:24 UTC
(In reply to jzmigrodzki from comment #2)
> Created attachment 113839 [details]
> ODT file with problematic bibliography
> 
> I added ODT file with bibliografy in which this problem ocure.

Reproduced with the document.

1. Right-click bibliog. on pg 4. - Edit Index/Table
2. Entries - Press the Au in Structure
3. Select a character style from the dropdown, OK, style is applied
4. Reload document
5. Right-click bibliog. - Update Index/Table, the style disappears

Style only disappears on update, if the file has been saved and reloaded.

Bug 77919 is similar, but in it, one does not have to save & reload to lose the style.

3.3.0 and 3.5.0 in Ubuntu could not open the document.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 7c0eb12009496a35c927cd5b2520f9c34d50860b
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-03_10:52:12
Locale: fi_FI

Ubuntu 14.10 64-bit Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 4 Gordo 2015-04-11 18:27:14 UTC
I would like to add that every time a document with a bibliography is saved, even without adding any new biblio entries or updating the index, the index-entry-bibliography text:style-name in content.xml has extra data added to it.

In the Entries tab of Edit Index/Table, every time the tab is switched back and forth or the Type is selected back and forth, or even just visiting the Entries tab and OKing, causes extra data to be added to the style-name for each element in the Type.  You can see it in the tooltips.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 5 Buovjaga 2015-04-17 18:28:09 UTC
Apologies for being so silly to confirm the same bug twice on the same day and not noticing..

*** This bug has been marked as a duplicate of bug 77919 ***