Bug Hunting Session
Bug 89660 - UX: open Wiki page with information on new or changed behavior, detecting when user makes first use of a new version
Summary: UX: open Wiki page with information on new or changed behavior, detecting whe...
Status: RESOLVED DUPLICATE of bug 69042
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyInteresting, easyHack, skillCpp
Depends on:
Blocks: Help Dialog-Msgbox
  Show dependency treegraph
 
Reported: 2015-02-25 19:48 UTC by Cor Nouws
Modified: 2019-03-28 14:24 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-02-25 19:48:44 UTC
as per subject
Comment 1 Cor Nouws 2015-02-25 20:08:35 UTC
Can either be a small dialog linking to a wiki/www, 
or a document (why not) showing the info,
or ..
Comment 2 Yousuf Philips (jay) (retired) 2015-02-25 20:23:15 UTC
Was wondering why you set this as documentation.
Comment 3 Cor Nouws 2015-02-25 20:30:19 UTC
(In reply to Jay Philips from comment #2)
> Was wondering why you set this as documentation.

Isn't that about informing the user?
Other component fine for me too :)
Comment 4 V Stuart Foote 2015-02-25 20:32:41 UTC
Q. Can we detect when a users profile shows they are coming from a prior build? I know we can tell if it is a new default profile.

Finding a landing page in Wiki is probably the way to do this. 

The Web page now offers the release-notes as a guided landing page referring to Wiki-- http://www.libreoffice.org/download/release-notes/

But the detailed notes in the Wiki while covering major features and enhancments don't really have a focused topic addressing migrating users. Maybe need something like:

Are you an experienced LibreOffice user? "What has changed or been added to UI/UX that you need to know about in migrating your profile."

That Wiki would need to be authored, but also a means to detect when launch is using a revised version.
Comment 5 Thomas Lendo 2017-10-19 21:22:31 UTC
I see a problem with such solution because of localization or missing localization of wiki pages. Where should such information be linked if there is no page in the user's language. English as fallback is no good usability as you can't expect that everyone will understand it. That causes an angry user.

Personally I see the only chance in having such information linked from within the software if it can be disabled/hidden if there is no localization available or it must be built-in so that the text can be translated and maintained like other LibO strings.

Adding Sophie to CC list.
Comment 6 Yousuf Philips (jay) (retired) 2017-10-19 22:10:44 UTC
Sounds like we could create a 'What's New' message box dialog, which could also be listed in the help, and it could ask a simple question like 'Would you like to know the new features and improvements that were introduced in this version?' and pressing yes could open up the release notes wiki page (example[1]) in your browser, or alternatively a bundle release notes file, like the LICENSE.fodt file we currently ship through the Help > License Information... dialog.

Heiko, Olivier: thoughts.

[1] https://wiki.documentfoundation.org/ReleaseNotes/6.0
Comment 7 Heiko Tietze 2017-10-20 06:59:01 UTC
This request is a FDI, frequently discussed idea. I'm with the people who dislike when a message box pops up unwanted. Nothing to say against a shortcut to the release notes via Help > Release Notes - better use this terminology instead of Help > What's New as it adds confusion.
Comment 8 Heiko Tietze 2018-06-27 08:20:38 UTC
So we either need a new UNO command / menu entry which links to a wiki page and/or introduce a message box that asks in case of a new version whether or not this link should be opened. The localization should be taken into account.

Could be an interesting easyhack.
Comment 9 Cor Nouws 2018-11-09 13:50:48 UTC
suggesting to add this one and bug 91441 and bug 69042 to the UX agenda for evaluation and hopefully one (?) sensible plan.
Comment 10 Thomas Lendo 2019-03-27 19:03:57 UTC
See also Bug 69042 - Add a "Release Notes/What's New" window to be shown upon first run
Comment 11 Heiko Tietze 2019-03-28 14:24:50 UTC
Let's discuss the idea on one ticket.

*** This bug has been marked as a duplicate of bug 69042 ***