Bug Hunting Session
Bug 89693 - UI: Insert Index Entry and Edit Index Entry dialog boxes block viewing of document and side panel
Summary: UI: Insert Index Entry and Edit Index Entry dialog boxes block viewing of doc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2015-02-26 20:41 UTC by MartinPC
Modified: 2017-07-21 09:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MartinPC 2015-02-26 20:41:26 UTC
Serious indexing work is typically done in dedicated indexing sessions rather than on the fly. Accordingly, the Insert Index Entry and sometimes the Edit Index Entry are left open rather than repeatedly opened and closed. The problem is that these dialog boxes are rather large (and can auto-expand horizontally to become even larger) and, unless constantly dragged out of the way, can interfere with seeing what is in the document or in the side panel. I can see several possible solutions to this problem:

(1) Make the Insert Index Entry and Edit Index Entry dialog boxes minimizable/restorable. 

(2) Make the Insert Index Entry and Edit Index Entry dialog boxes "iconizable"-- basically the same as mimimizing, but with a special, conspicuous icon somewhere in Writer that you can click on to restore the dialog box.

(3) Make the Insert Index Entry and Edit Index Entry dialog boxes "dockable" in the side panel. Because the side panel is relatively narrow, this would probably require making the indexing field boxes vertically auto-expandable, to accommodate multiple lines.

This is a usability rather than a functionality bug, but any of the above solutions, especially the third, would make long indexing sessions a little less onerous.
Comment 1 Buovjaga 2015-02-27 13:32:02 UTC
You know what? I'll send this to the design team to figure out!
Comment 2 Robinson Tryon (qubit) 2016-08-25 04:44:56 UTC Comment hidden (obsolete)
Comment 3 Heiko Tietze 2017-07-21 09:25:13 UTC
1) The dialog can be minimized on Linux which makes absolutely no sense as you cannot restore it
2) Sounds like a lot of effort, and you end up in continuously switching between the two window states
3) Having a sidebar deck would be okay

But I don't see a big issue with the dialog. It has a minimum size of 424x343px that shouldn't bother too much in the 'dedicated indexing session' (it would if you work parallel on the text). Therefore it's a WFM.