Bug 89728 - Moving SVGs is unusably slow.
Summary: Moving SVGs is unusably slow.
Status: RESOLVED DUPLICATE of bug 83426
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-27 18:12 UTC by Timothy Miller
Modified: 2015-10-19 14:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG image that makes Impress take excessive CPU time. (228.63 KB, image/svg+xml)
2015-02-27 18:12 UTC, Timothy Miller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Miller 2015-02-27 18:12:55 UTC
Created attachment 113760 [details]
SVG image that makes Impress take excessive CPU time.

I have an SVG file I inserted into an Impress slide.  I have a fast Mac with a lot of memory, but moving it around is unusably slow.  Just moving it with the arrow keys, the CPU fans spin up.  This image (attached) is not that complicated.
Comment 1 V Stuart Foote 2015-02-28 21:55:22 UTC
Can not confirm on Windows 7 sp1, 64-bit en-US with

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_US

However, please recheck with the current 4.4.1.2 release build, or even the current daily of master -- http://dev-builds.libreoffice.org/daily/master/

You might compare behavior of this SVG with the troublesome squirrel SVG attached to bug 88277. Also note that LibreOffice uses two different filters--one for import Open into Draw, and a second for insert as image into any of the components. The two filters differ in structure and can manifest different issues. The "rasterizer.svg" performed about the same with both on Windows.
Comment 2 raal 2015-03-01 21:39:44 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: a2fa9e2468aa5c4fd4b610c5d0ebc8959e87a072
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-23_02:34:05

100% CPU when moving picture with keys
Comment 3 V Stuart Foote 2015-03-24 23:30:31 UTC
Still not seeing an issue with Linux 32-bit (Fedora 21 w/LXDE) or Windows 7 sp1 64-bit

The Linux is a VM (VMWare workstation 11, w/4GB Ram on an HDD), VM CPU use ~35-40% when moving the multi-element SVG.  On the 64-bitWindows system, 12 GB Ram i7--920 @2.7GHz, 32-bit LO peaked ~24% CPU during movement.  64-bit build LO ~23% CPU during movement.


Version: 4.5.0.0.alpha0+
Build ID: c3087d969671e62182eb049850479e77190ccff4
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-22_02:33:12
Locale: en_US

Version: 4.5.0.0.alpha0+
Build ID: 0b0dbd64bb589a6f0ab981f9740fff1dc500a055
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-23_23:15:13
Locale: en_US

Version: 4.5.0.0.alpha0+ (x64)
Build ID: c3087d969671e62182eb049850479e77190ccff4
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-03-22_00:38:19
Locale: en_US
Comment 4 V Stuart Foote 2015-10-19 14:49:12 UTC
Duping this to bug 83426

Complex SVGs in Impress degrade presentation mode--but they also disrupt slide editing as in this extreme example.

*** This bug has been marked as a duplicate of bug 83426 ***