Download it now!
Bug 89777 - Wrong number of pages after mailing
Summary: Wrong number of pages after mailing
Status: RESOLVED DUPLICATE of bug 101452
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2015-03-02 11:41 UTC by yvan
Modified: 2016-10-05 10:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
example of mail merge result (9.54 KB, application/vnd.oasis.opendocument.text)
2015-03-02 11:41 UTC, yvan
Details
example of data source (17.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-11 09:44 UTC, yvan
Details
example of master document to do a mail merge (11.45 KB, application/vnd.oasis.opendocument.text)
2015-03-11 09:45 UTC, yvan
Details
example of mail merge result using the master and data sources provided (11.08 KB, application/vnd.oasis.opendocument.text)
2015-03-11 09:46 UTC, yvan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yvan 2015-03-02 11:41:59 UTC
Created attachment 113821 [details]
example of mail merge result

Hi,

After doing a mail merge, the resulting Writer document should normally have: total page number = number of pages of the master document * number of records in the database.

Instead, the total page number shown at the bottom left is doubled.

Also, when you scroll down, the current page number jumps from 1 to 3, then 5, then 7, an so on.

What I tested :
 - LibreOffice 4.4.1.2 and 4.3.5.2 on Windows 7
 - tested with different master documents of one page
 - tested with two .ods sheets coming from different documents
 - mailing is done by selecting a database with "Edit->Switch Database", then inserting fieds from the data source (F4), and then merging with "Mailing assistant"

Please let me know if I can provide more informations,
YvanM
Comment 1 Buovjaga 2015-03-05 12:02:35 UTC
Can you provide an example document with a data source? Thanks.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 yvan 2015-03-11 09:44:35 UTC
Created attachment 114035 [details]
example of data source
Comment 3 yvan 2015-03-11 09:45:10 UTC
Created attachment 114036 [details]
example of master document to do a mail merge
Comment 4 yvan 2015-03-11 09:46:04 UTC
Created attachment 114037 [details]
example of mail merge result using the master and data sources provided
Comment 5 Buovjaga 2015-03-11 11:24:10 UTC
Reproduced using data source + master document provided.

Notes for testers:
Open test.odt
Edit - Exchange database
Browse - Select test.ods
Expand test, select Feuille1 and click Define
Tools - Mail Merge Wizard - 1. Use current doc / 2. Letter / 8. Save merged doc, save as single doc

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Ubuntu 14.10 64-bit
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 6 yvan 2015-03-11 13:44:24 UTC
Still on Windows 7, after:
 - upgrading to LibreOffice 4.3.6.2 build ID d50a87b2e514536ed401c18000dad4660b6a169e
 - resetting my user profile
 - creating a new data source from scratch
 - merging a new document from scratch

The issue is still here.

Thanks again for your time and work,
Yvan
Comment 7 tommy27 2016-04-16 07:23:14 UTC Comment hidden (obsolete)
Comment 8 yvan 2016-04-18 10:51:26 UTC
Hi tommy27,

You are right, it is good thing to test if the bug is still here.

Unfortunately, it has not been solved yet (I believe there has been no work on the mail merge wizard since a long time): I reproduced the bug on Debian Unstable, with LibreOffice 5.1.2.2 x86_64 from libreoffice.org (build ID d3bf12ecb743fc0d20e0be0c58ca359301eb705f).

Regards,
Yvan
Comment 9 Jan-Marek Glogowski 2016-10-05 10:40:31 UTC
101452

*** This bug has been marked as a duplicate of bug 101452 ***