Bug Hunting Session
Bug 89902 - WRITER: Drawing properties toolbar: Turn area filling color into split button
Summary: WRITER: Drawing properties toolbar: Turn area filling color into split button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Michael Horn
URL:
Whiteboard: color_handling
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
Depends on:
Blocks: 45671
  Show dependency treegraph
 
Reported: 2015-03-09 12:18 UTC by Jacobo Aragunde Pérez
Modified: 2016-02-18 16:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2015-03-09 12:18:21 UTC
There are still some old color choosers in some less used places of the UI. One of these is the Drawing Object Properties toolbar. For more info, see: bug 45671.

How to get to see it:
* Open Writer.
* Add a shape with the Drawing toolbar or with the Basic shapes button.

Result: Drawing Object Properties toolbar appears on top, below the Standard toolbar.
* In that toolbar there are two color selectors, one for the line color and the other one for the background color. The latter still uses the old format.

You can see how this UI element should be in the in the properties sidebar, where it's been already updated.
Comment 1 Jacobo Aragunde Pérez 2015-03-09 12:19:29 UTC
I think this qualifies for an easy hack, like other similar bugs before.
Comment 2 Tomaz Vajngerl 2015-03-09 12:46:13 UTC
It is not so simple because background color can also be gradient, hatching or bitmap. So we need to upgrade the color picker to handle all those too before we can exchange.
Comment 3 Jacobo Aragunde Pérez 2015-03-09 12:52:49 UTC
(In reply to Tomaz Vajngerl from comment #2)
> It is not so simple because background color can also be gradient, hatching
> or bitmap. So we need to upgrade the color picker to handle all those too
> before we can exchange.

The solution chosen for the sidebar is using the new color picker when "color" is selected in the fill type combo, and using the old pickers for the other cases ("gradient", "hatching", etc.).
Comment 4 A (Andy) 2015-03-14 07:52:59 UTC
Reproducible with LO 4.4.1.2, Win 8.1

I like the new colour picker and it would be great if this could also be implemented for the Area fill in this case.

Note to users: The mentioned toolbar is only visible if you have activated it with VIEW -> TOOLBARS -> DRAWING OBJECTS PROPERTIES
Comment 5 Michael Horn 2015-03-25 23:17:59 UTC
I'd like to work on this issue, so I'll be assigning it to myself. Will post progress updates periodically.
Comment 6 Michael Horn 2015-03-26 23:08:35 UTC
The issue is a bit more complicated than it first appeared to be. I'd still like to work on it, but I'm spending some time reading the dev guide and other docs. If anyone feels like they can get this done more quickly, they're free to take over and let me know :)
Comment 7 Robinson Tryon (qubit) 2015-12-14 06:37:05 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp TopicUi)
[NinjaEdit]
Comment 8 jani 2016-02-11 13:00:17 UTC
Missing code pointer
Comment 10 Robinson Tryon (qubit) 2016-02-18 16:37:18 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]