Bug 89939 - FILEOPEN XLS using Import Options Auto Data Missing
Summary: FILEOPEN XLS using Import Options Auto Data Missing
Status: RESOLVED DUPLICATE of bug 51345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-10 20:49 UTC by Mateo
Modified: 2015-03-20 17:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
FROM AS400 SYSTEM (599.19 KB, application/vnd.ms-excel)
2015-03-10 20:49 UTC, Mateo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateo 2015-03-10 20:49:22 UTC
Created attachment 114026 [details]
FROM AS400 SYSTEM

Our AS400 application kicks out reports in this format. MS Office (any version) opens after prompting "File format and extension doesn't match." Hit yes and it opens fine.Completely readable.
LO 4.3.5.2 opens the "Import Options" prompt and I select OK (Automatic) and the file opens. BUT, most of the data is missing. The header rows are present and a summary row at very bottom.
Comment 1 raal 2015-03-11 12:05:33 UTC
It's a xml file with .xls extension
Comment 2 Mateo 2015-03-11 20:05:42 UTC
(In reply to raal from comment #1)
> It's a xml file with .xls extension

Is there a way to open this type of file (xml) with LO?
Comment 3 raal 2015-03-12 06:53:01 UTC
(In reply to Mateo from comment #2)
> (In reply to raal from comment #1)
> > It's a xml file with .xls extension
> 
> Is there a way to open this type of file (xml) with LO?

Probably yes, look here: https://help.libreoffice.org/Common/Creating_XML_Filters
Comment 4 Buovjaga 2015-03-20 17:20:09 UTC
Requested comment from Eike Rathke and got it: LibreOffice doesn't yet support the x:str and x:num attributes.

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 51345 ***