Download it now!
Bug 89942 - Draw created shapes fail to copy into Writer properly.
Summary: Draw created shapes fail to copy into Writer properly.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-10 22:32 UTC by bugzilla
Modified: 2015-04-14 17:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example Draw file and Writer file (43.53 KB, application/x-7z-compressed)
2015-03-11 15:55 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2015-03-10 22:32:02 UTC
I've experienced two major defects when copying DRAW created shapes into a Writer document. (Using LO 4.4.0.3 in Win7)

1) When a single shape (circle, rectangle) is copy/pasted from Draw to Writer, it appears to transfer properly, but is missing (deleted) when Writer document reloaded.  This happens whether the shape is placed on the page or in a frame.
Note:	a) If two or more DRAW shapes are grouped then copied, the problem does not occur.
	b) Lines and connectors never exhibit this problem, just circles, rectangles etc.
	c) A shape originally created in Writer, copied to Draw, then copied back to Writer does not cause any problems.
	
2) When objects created in Draw are grouped then copied into a Writer frame, the circles and rectangles always remain in the background. This means that unless the frame area has Transparency= 100%, the objects may be obscured (at first I thought missing).
Note:	a) Lines and connectors never exhibit this problem, just circles, rectangles etc.
	b) A shape originally created in Writer, copied to Draw, then copied back to Writer does not cause any problems.

I'm evaluating LibreOffice as a replacement for MS Office and defects such as this are quite alarming and tarnish the first impression of LO.  In this case there is a workaround, but it took a bit of searching/testing to figure it out, and could easily put off a new user. A permanent fix would greatly improve the new-adopter experience.
Comment 1 V Stuart Foote 2015-03-11 05:26:33 UTC
So have a check and convince yourself if this is issue of bug 86578 

Create the shapes in Draw but use fills other than color (bitmap or gradient). Copy them into a Writer session. Are they stable?
Comment 2 bugzilla 2015-03-11 15:55:35 UTC
Created attachment 114041 [details]
Example Draw file and Writer file

As suggested I've tried various background options. Firstly frame area Gradient, Hatching and Bitmap, and the results are the same as for Colour.  I also confirm that on Writer document reload, the frame is always reset to Transparency= Solid 100%, regardless of the original setting (as detailed in Bug 86578).
 
Using "Paste Special ..." with Draw8, Drawing format, GDI Metafile & Bitmap, confirmed the problem only occurs with the Drawing format (I presume equivalent to simple Cut/Paste).
 
Also created Draw shapes with hatching and bitmap backgrounds, problem same as with colour background.
 
See attached 7z file containing a sample Draw file and Writer file.
 
What I'm observing is the issue where Draw shapes (circles, rectangles etc) 
copied into a Writer frame, become stuck behind the frame background. However any Draw lines and all Writer generated shapes remain in the foreground (as intended).  Thus any frame transparency less than 100% causes Draw shapes to fade to varying degrees (or disappear at <10%). This is my major concern.
  
My other observation that a single Draw shape copied to Writer and placed on the page or in a frame (circle, rectangle) always vanishes after reload, may have a different root cause. Howver as most people are likely to create a simple shape directly in Writer rather than copy from Draw, it is not a major issue.
Comment 3 bugzilla 2015-03-14 20:30:51 UTC
I've added my latest findings on 11 March but forgot to update the status, here goes ..
Comment 4 V Stuart Foote 2015-04-14 17:02:53 UTC
Believe these are correct now in current master.

Version: 4.5.0.0.alpha0+ (x64)
Build ID: 79f64d75b25ebb7fdf9f827218cd8a762dc2739b
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-14_05:46:17
Locale: en_US