Bug 89953 - UI, Formatting: Character spacing
Summary: UI, Formatting: Character spacing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-11 10:14 UTC by Alex
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2015-03-11 10:14:50 UTC
There are several issues with the character spacing menu in LibreOffice Writer:

1. If there are 2 or more types of character spacing within the selected text (lets say, one word is expanded by 0.5pt and another word next to it is condensed by 0.2pt), the character spacing menu (Format > Character > Position > Spacing) shows 'default' (but it's not default, because it's not 0), and when I click 'default' and OK, the spacing doesn't change (in the same situation in MS Office Word the spacing changes to 0pt for both words), so I have to adjust every word manually which is not correct. 

2. The spacing is adjusted by 1.0pt, but it would be more convenient if it's 0.1pt for small or normal fonts (~8-16pt). 

3. You have to select the type of spacing first ('Expanded' or 'Condensed'), before you can adjust the numbers (if the type is not selected, the field is disabled), but it would be more comfortable to set the value of spacing directly using arrows (up for expanded and down for condensed) or just write the numbers into the field (with + or - respectively).
Comment 1 A (Andy) 2015-03-11 21:05:24 UTC
(In reply to Alex from comment #0)
> There are several issues with the character spacing menu in LibreOffice
> Writer:
> 
> 1. If there are 2 or more types of character spacing within the selected
> text (lets say, one word is expanded by 0.5pt and another word next to it is
> condensed by 0.2pt), the character spacing menu (Format > Character >
> Position > Spacing) shows 'default' (but it's not default, because it's not
> 0), and when I click 'default' and OK, the spacing doesn't change (in the
> same situation in MS Office Word the spacing changes to 0pt for both words),
> so I have to adjust every word manually which is not correct. 

Reproducible with LO 4.4.1.2, Win 8.1

> 2. The spacing is adjusted by 1.0pt, but it would be more convenient if it's
> 0.1pt for small or normal fonts (~8-16pt). 

I can live with the current solution, but maybe other users think also different about this.

> 3. You have to select the type of spacing first ('Expanded' or 'Condensed'),
> before you can adjust the numbers (if the type is not selected, the field is
> disabled), but it would be more comfortable to set the value of spacing
> directly using arrows (up for expanded and down for condensed) or just write
> the numbers into the field (with + or - respectively).

For me this sounds like a good and reasonable enhancement proposal.  But it would be better to open a separate enhancement request for this, because it is not linked to the bug mentioned in No. 1.
Comment 2 tommy27 2016-04-16 07:23:37 UTC Comment hidden (obsolete)
Comment 3 Commit Notification 2016-04-22 14:50:27 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9a745d54a5c7470180f41494283983a3b8b84a51

tdf#89953 Character spacing: Allow to enter negative values

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-04-22 14:50:31 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db18de5868454ed5c242d54e483ea8f403a80601

tdf#89953 Character spacing: Increment by 0.1, not by 1

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-04-25 07:58:40 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b68a722ff5ed70ce4a7d2eaffd972cb3fd0922bc

tdf#89953 Character spacing: Apply changes to sidebar widget also

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Samuel Mehrbrodt (CIB) 2016-04-25 08:03:15 UTC
(In reply to Alex from comment #0)
> 1. If there are 2 or more types of character spacing within the selected
> text (lets say, one word is expanded by 0.5pt and another word next to it is
> condensed by 0.2pt), the character spacing menu (Format > Character >
> Position > Spacing) shows 'default' (but it's not default, because it's not
> 0), and when I click 'default' and OK, the spacing doesn't change (in the
> same situation in MS Office Word the spacing changes to 0pt for both words),
> so I have to adjust every word manually which is not correct. 

@Oliver, any idea how to fix this issue?
Comment 7 Oliver Specht (CIB) 2016-04-25 08:18:28 UTC
I would unselect the ListBox as in https://gerrit.libreoffice.org/#/c/24361/
Comment 8 Commit Notification 2016-04-25 21:45:54 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7b6a881fae188afa224c71cd4685fabe80ac47fc

tdf#89953 Help update for character spacing controls’ simplification
Comment 9 Commit Notification 2016-04-26 11:36:30 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3572701cf5481edc7432b062e0fa69697c212be

tdf#89953: put zero kerning if item state has been invalid

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.