Bug 90025 - Copying conditionally formatted cells
Summary: Copying conditionally formatted cells
Status: RESOLVED DUPLICATE of bug 80768
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-15 17:34 UTC by Lenge
Modified: 2015-04-27 02:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lenge 2015-03-15 17:34:17 UTC
I'd like to propose an enhancement to handling conditionally formatted cell ranges when cells are copied.

Example: Cell range B2:B10 is conditionally formatted. The list delivered by "Format\Conditional Formatting\Manage..." has a single entry for B2:B10.

Current behavior:

a) Copying inside the same CF range: When cell B4 is copied to B8, the CF range is split into three independent ranges (B2:B7, B8, and B9:B10) with the exact same conditional formatting.

b) Copying from within the CF range to the outside: When cell B4 is copied to D4, an new CF range is created for D4 with the exact same conditional formatting.

Proposed behavior:

a) When cells from within the range are copied to a destination that is also within the same existing CF range, the range should remain exactly as is. In the above example, there would be a single CF range "B2:B10" even after the copying.

b) When cells from within the range are copied to a destination outside the range, the existing CF range should be extended to include the destination. In the above example, there would be a single CF range "B2:B10;D4" after the copying.

The principle could then be extended to copying multiple cells or cell ranges, and maybe the corner case where the destination range partly overlaps with the original CF range. In effect, splitting CF ranges into independent smaller ranges with identical formatting should be avoided wherever possible.
Comment 1 raal 2015-03-15 18:00:02 UTC
Hello Lenge,

Thank you for reporting the bug. Can you see if bug 80768 is similar to your problem so that I can mark your report as a duplicate of it? (Later bugs are generally marked as duplicates of earlier bugs).
Comment 2 Lenge 2015-03-15 18:09:08 UTC
I'd say it is related, but not exactly a duplicate. Maybe we could link the issue without setting this one as a dupe, at least until an expert with more in-depth knowledge can decide if it is one or not.
Comment 3 Matthew Francis 2015-04-27 02:51:56 UTC
The comments to bug 80768 aren't especially legible, but the point of both bugs is that "conditional formatting ranges should be consolidated where possible rather than endlessly multiplying", so one bug open should be enough

*** This bug has been marked as a duplicate of bug 80768 ***