Bug 90094 - Save document thumbnails out of the user profile xcu file
Summary: Save document thumbnails out of the user profile xcu file
Status: RESOLVED DUPLICATE of bug 99716
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: User-Profile Save
  Show dependency treegraph
 
Reported: 2015-03-19 06:01 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-05-18 22:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-03-19 06:01:03 UTC
Currently thumbnails are stored textually inside the user profile's registrymodifications.xcu file and i believe it would be better to simply store the pngs inside a separate folder.
Comment 1 V Stuart Foote 2015-03-19 12:41:53 UTC
Yes, this would make sense, but only if there is no performance impact on function of the thumbnail view panel in the Start Center. And, suspect there would still need to be file pointers present in the .xcu to either the fully rendered thumbnail, or a suitable icon--when encrypted, or if a non-thumbnailed format.
Comment 2 Yousuf Philips (jay) (retired) 2015-03-19 21:42:29 UTC
Doubt there would be any performance impact for such an improvement and it would reduce the size of the xcu file, which is another plus to reduce possible corruption of the file.

I'd assume the simplest means of naming the thumbnail is to have it as the md5 or sha1 of the file's path and store it in a [user profile dir]/user/thumbnails/ folder.
Comment 3 Robinson Tryon (qubit) 2016-08-25 05:26:57 UTC Comment hidden (obsolete)
Comment 4 V Stuart Foote 2016-11-15 13:37:26 UTC
@Jay, sorry I'm dup'ing this out to more active 99716, nothing overly substantive here.

*** This bug has been marked as a duplicate of bug 99716 ***