Download it now!
Bug 90120 - Editing: Pasting text to Writer from web, e-mail or documents sometimes doesn't work, it's a random beahaviour.
Summary: Editing: Pasting text to Writer from web, e-mail or documents sometimes doesn...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 131865 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-20 01:52 UTC by Sal
Modified: 2020-05-04 15:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sal 2015-03-20 01:52:25 UTC
Bug in Writer: 
Sometimes pasting text from web or documents doesn't work. This is a very random bug. Often the paste symbol is not visible in writer after copying text from web or documents. Not even the command Control+V work. If I start a new writer document it often works again.
Comment 1 Sal 2015-03-20 05:45:51 UTC
One example of random behaviour. 
Sometimes I copy text from an e-mail in to Writer. 
One second later I can no longer do it, not even the exact same text part I just pasted in to Writer. If I close and reload or start a new Writer document, pasting mostly works again after that.
Comment 2 Buovjaga 2015-03-21 18:16:02 UTC Comment hidden (obsolete)
Comment 3 Sal 2015-03-21 23:06:47 UTC
It has happened when copying text (single words and also bigger sections) from e-mails in yahoo.com, from LO Writer documents to another LO Writer document, from several different web pages. 
It happens randomly so several tries needs to be done to reproduce it.
Comment 4 Sal 2015-03-22 03:33:44 UTC Comment hidden (obsolete)
Comment 5 Jürgen 2015-03-23 08:31:07 UTC
Very seldom the error occurs while pasting text from Thunderbird-Mail-Content into Writer (< 5 Lines).
I found a little "workaround": When error occurs, I copy a bit of text from the Target-Document, paste in into the same document and then retry the first copy-paste-action. After this action, paste works normal again. Don't know why, but it helps :-)
Comment 6 Colin 2016-02-19 09:41:14 UTC
I can re-produce part of this bug reliably by doing the following on Windows with Libre Writer version 5.0.4.2.

Copy a word from a .hpp document in Visual Studio 2010 using Ctrl+C.
Create a new document in Writer and paste option is not available.

I created a test .hpp document with the following content to replicate the problem (use this example exactly):
class TestClass
{

    TestData m_test_data;
};

Steps:
1. In Visual Studio I simply double click TestData word and click Ctrl+C to copy the word.
2. I start Writer, create a heading with Heading 1 and call the Heading Test, then press enter to go onto the next line.
3. I then use right mouse button click for context menu, and the paste and paste-special options are disabled.

My only change in Libre office from default installation is I have changed the next style to be Default text instead of heading, so after typing in the Test text within the header 1 style, I press enter for the next line where I then paste into the Default text style.

The part that is random is using Ctrl+V to paste, sometimes it works and sometimes it doesn't.
The right click context menu for paste and paste-special are always disabled when I do this.

So there could possibly be two bugs here, one where the copy/paste buffer is not being handled properly, and another where the context menu is handling buffer state differently from the keyboard shortcut (Ctrl+V).

I've also noticed it's more of a problem when there are headings in the document.

I am running Windows 7 (64-bit), which is up to date on patches.
Comment 7 Mike A. Harris 2016-07-14 05:45:18 UTC
I can reproduce this issue on 5.1.4.2 on Win7/x64 in LO Calc, trying to paste from Firefox, Thunderbird, Chrome from HTML source.  Paste special sometimes works, most of the time it is not even on the context menu and unavailable, and regular paste is gone or greyed out with the only thing showing being Paste only and it has a single item on the submenu "No selection available", however I can switch to Notepad or some other app and paste from the clipboard no problem.

When this occurs, if I save the document, exit Calc, open calc and reload the document, then right click in the same cell on the spreadsheet, magically Paste Special and the rest of the options are back again and they work once.

Go back to the web page and highlight new text and try to copy it over again (or in an HTML email from Thunderbird or similar) and the problem recurs.

Happened to me about 50 times today.  Interestingly, pasting the keyboard buffer to an intermediate non-HTML application such as Windows Notepad, then reselecting the text in Notepad and pasting it into Calc it usually works.  Going direct from Firefox/Thunderbird/Chrome with HTML source or from something with RTF source results in missing options on the context menus, or greyed out features.  Once it has happened the app behaves oddly with various other bugs/glitches until it is restarted also (if it doesn't crash on its own).
Comment 8 Buovjaga 2016-07-15 17:35:09 UTC
I guess we have enough confirmations, so setting to NEW.
Comment 9 QA Administrators 2017-09-01 11:16:20 UTC Comment hidden (obsolete)
Comment 10 Timur 2019-10-09 13:51:01 UTC
We don't have steps here to confirm, but I also experience this bug.
My solution used to be extension "Pate from Web" that worked exactly in those situations when normal paste wasn't available. Only it shows errors sometimes because it's not maintained.
Comment 11 Timur 2020-05-04 15:04:02 UTC
*** Bug 131865 has been marked as a duplicate of this bug. ***